aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-01-18 14:39:30 -0800
committerKhem Raj <raj.khem@gmail.com>2022-01-19 09:01:04 -0800
commitec2cfccc2a4f3141a80ba1cf3b439f06b39c470a (patch)
treed3149917223c8c64a100021d1f1160c157f01af7
parent18902d643b00bb301137f256811b63b4ded4415c (diff)
downloadmeta-openembedded-contrib-ec2cfccc2a4f3141a80ba1cf3b439f06b39c470a.tar.gz
iotop: Use lld with clang on arm
BFD linker is crashing when using clang, workaround it by always using lld when using clang on arm Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/iotop/iotop_1.20.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/iotop/iotop_1.20.bb b/meta-oe/recipes-extended/iotop/iotop_1.20.bb
index 17c567095b..b05c8cd35d 100644
--- a/meta-oe/recipes-extended/iotop/iotop_1.20.bb
+++ b/meta-oe/recipes-extended/iotop/iotop_1.20.bb
@@ -12,6 +12,10 @@ inherit pkgconfig
EXTRA_OEMAKE = "V=1 STRIP=true"
+# Workaround BFD linker crash with clang on arm
+# revisit when upgrading binutils and see if its fixed
+LDFLAGS:append:toolchain-clang:arm = " -fuse-ld=lld"
+
do_install() {
oe_runmake install DESTDIR=${D}
}