aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRamon Fried <rfried.dev@gmail.com>2020-12-15 22:45:42 +0200
committerKhem Raj <raj.khem@gmail.com>2020-12-15 21:29:18 -0800
commit3ef806b2a0cb9dc6614ab75b365c932aa1f9bc4c (patch)
treeef3497501ae9bf8373da65cfba6252208a6f49ad
parentf03ad4971ed0b7cf34550a90ee3c0fa18f964533 (diff)
downloadmeta-openembedded-contrib-3ef806b2a0cb9dc6614ab75b365c932aa1f9bc4c.tar.gz
bitwise: add new recipe
Bitwise is multi base interactive calculator supporting dynamic base conversion and bit manipulation. It's a handy tool for low level hackers, kernel developers and device drivers developers. Signed-off-by: Ramon Fried <rfried.dev@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb1
-rw-r--r--meta-oe/recipes-extended/bitwise/bitwise_0.41.bb24
-rw-r--r--meta-oe/recipes-extended/bitwise/files/0001-makefile.am-Fix-build-when-build-dir-is-not-same-as-.patch29
3 files changed, 54 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
index 2c46d21b70..577f2e7886 100644
--- a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
+++ b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
@@ -307,6 +307,7 @@ RDEPENDS_packagegroup-meta-oe-devtools_remove_x86-64 = "${@bb.utils.contains("TU
RDEPENDS_packagegroup-meta-oe-devtools_remove_x86 = "ply"
RDEPENDS_packagegroup-meta-oe-extended ="\
+ bitwise \
${@bb.utils.contains("DISTRO_FEATURES", "x11 wayland opengl", "boinc-client", "", d)} \
brotli \
byacc \
diff --git a/meta-oe/recipes-extended/bitwise/bitwise_0.41.bb b/meta-oe/recipes-extended/bitwise/bitwise_0.41.bb
new file mode 100644
index 0000000000..0378227817
--- /dev/null
+++ b/meta-oe/recipes-extended/bitwise/bitwise_0.41.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Bitwise terminal calculator"
+DESCRIPTION = "Bitwise is multi base interactive calculator \
+supporting dynamic base conversion and bit manipulation.\
+It's a handy tool for low level hackers, \
+kernel developers and device drivers developers."
+
+HOMEPAGE = "https://github.com/mellowcandle/bitwise"
+SECTION = "console/utils"
+
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
+
+SRC_URI = "https://github.com/mellowcandle/bitwise/releases/download/v${PV}/bitwise-v${PV}.tar.gz \
+ file://0001-makefile.am-Fix-build-when-build-dir-is-not-same-as-.patch \
+ "
+SRC_URI[sha256sum] = "33ce934fb99dadf7652224152cc135a0abf6a211adde53d96e9be7067567749c"
+
+UPSTREAM_CHECK_URI = "https://github.com/mellowcandle/bitwise/releases"
+
+S = "${WORKDIR}/${BPN}-v${PV}"
+
+DEPENDS = "ncurses readline"
+
+inherit autotools
diff --git a/meta-oe/recipes-extended/bitwise/files/0001-makefile.am-Fix-build-when-build-dir-is-not-same-as-.patch b/meta-oe/recipes-extended/bitwise/files/0001-makefile.am-Fix-build-when-build-dir-is-not-same-as-.patch
new file mode 100644
index 0000000000..ad3f0bb1fd
--- /dev/null
+++ b/meta-oe/recipes-extended/bitwise/files/0001-makefile.am-Fix-build-when-build-dir-is-not-same-as-.patch
@@ -0,0 +1,29 @@
+From 2089b514045d2de64a5d9c54e241731e85d77df2 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 14 Dec 2020 22:11:59 -0800
+Subject: [PATCH] makefile.am: Fix build when build dir is not same as
+ sourcedir
+
+This ensures right include paths are added to compiler
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index eba85a1..da998ff 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -19,7 +19,7 @@ if COND_DEBUG
+ MAYBE_DEBUG=-g -O0
+ endif
+
+-AM_CFLAGS = $(MAYBE_COVERAGE) $(MAYBE_DEBUG) $(MAYBE_TRACE)
++AM_CFLAGS = $(MAYBE_COVERAGE) $(MAYBE_DEBUG) $(MAYBE_TRACE) -I$(srcdir)/inc
+
+ check_PROGRAMS = tests/test-shunting-yard
+ tests_test_shunting_yard_SOURCES = src/shunting-yard.c inc/shunting-yard.h \
+--
+2.29.2
+