aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Perrot <thomas.perrot@bootlin.com>2020-12-08 16:38:08 +0100
committerKhem Raj <raj.khem@gmail.com>2020-12-08 10:38:57 -0800
commit64bc3a36e4a36f16596c2f6e83998c8dccd717a6 (patch)
tree3caa9c3090b212737d908e9750a768fcabc8df91
parent646a9ebf6dcc40695440956d2b58bafdbc9133c7 (diff)
downloadmeta-openembedded-contrib-64bc3a36e4a36f16596c2f6e83998c8dccd717a6.tar.gz
openocd: disable the support of ccache
Otherwise, when ccache is enabled the following error occurs, by adding CCACHE_DISABLE = "1" in the recipe this is avoided. | No installed jimsh or tclsh, building local bootstrap jimsh0 | Host System...x86_64-pc-linux-gnu | Build System...x86_64-pc-linux-gnu | C compiler...ccache ccache gcc -isystem/src/build/tmp/work/x86_64-linux/openocd-native/0.10+gitrAUTOINC+ded6799025-r0/recipe-sysroot-native/usr/include -O2 -pipe | C++ compiler...ccache ccache g++ -isystem/src/build/tmp/work/x86_64-linux/openocd-native/0.10+gitrAUTOINC+ded6799025-r0/recipe-sysroot-native/usr/include -O2 -pipe | Build C compiler...ccache gcc | Checking for stdlib.h...not found | Error: Compiler does not work. See config.log | Try: 'configure --help' for options | configure: error: ./configure.gnu failed for jimtcl | WARNING: exit code 1 from a shell command. | Signed-off-by: Thomas Perrot <thomas.perrot@bootlin.com>
-rw-r--r--meta-oe/recipes-devtools/openocd/openocd_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/openocd/openocd_git.bb b/meta-oe/recipes-devtools/openocd/openocd_git.bb
index 4f6aaa8a6a..05e06a25d5 100644
--- a/meta-oe/recipes-devtools/openocd/openocd_git.bb
+++ b/meta-oe/recipes-devtools/openocd/openocd_git.bb
@@ -54,3 +54,6 @@ FILES_${PN} = " \
PACKAGECONFIG[sysfsgpio] = "--enable-sysfsgpio,--disable-sysfsgpio"
PACKAGECONFIG[remote-bitbang] = "--enable-remote-bitbang,--disable-remote-bitbang"
PACKAGECONFIG ??= "sysfsgpio remote-bitbang"
+
+# Can't be built with ccache
+CCACHE_DISABLE = "1"