aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-11-29 18:25:33 -0800
committerKhem Raj <raj.khem@gmail.com>2020-11-29 22:02:15 -0800
commitf623d8b5741a8d9060a6be025cfdcfa479dd3fb3 (patch)
tree1351f88c93e2b2c1f0b86c17f157af60b7ec547b
parentbf5aeb92c06c33c11b361853d0a0aaa5e0f61d33 (diff)
downloadmeta-openembedded-contrib-f623d8b5741a8d9060a6be025cfdcfa479dd3fb3.tar.gz
python3-matplotlib: Disable LTO for clang/riscv
LTO fails to link on RV32/RV64 | Hard-float 'd' ABI can't be used for a target that doesn't support the D instruction set extension ( ignoring target-abi) | riscv64-yoe-linux-ld.lld: error: lto.tmp: cannot link object files with different floating-point ABI Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-matplotlib_3.3.2.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib_3.3.2.bb b/meta-python/recipes-devtools/python/python3-matplotlib_3.3.2.bb
index a2e7074d78..3cfa3f31f4 100644
--- a/meta-python/recipes-devtools/python/python3-matplotlib_3.3.2.bb
+++ b/meta-python/recipes-devtools/python/python3-matplotlib_3.3.2.bb
@@ -38,9 +38,12 @@ RDEPENDS_${PN} = "\
python3-pytz \
"
+ENABLELTO_toolchain-clang_riscv64 = "echo enable_lto = False >> ${S}/setup.cfg"
+ENABLELTO_toolchain-clang_riscv32 = "echo enable_lto = False >> ${S}/setup.cfg"
do_compile_prepend() {
echo [libs] > ${S}/setup.cfg
echo system_freetype = true >> ${S}/setup.cfg
+ ${ENABLELTO}
}
BBCLASSEXTEND = "native"