aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2020-11-28 11:46:41 -0800
committerKhem Raj <raj.khem@gmail.com>2020-11-29 22:02:15 -0800
commitf627aa0003ff9ca020540353ab4ded32fcfc8d34 (patch)
tree5fa95dad90a1935152bd7ec64a01d7f10cbebc3e
parent885149082bbf2d9321439ccbe6e543e4c2c56ff2 (diff)
downloadmeta-openembedded-contrib-f627aa0003ff9ca020540353ab4ded32fcfc8d34.tar.gz
python3-atomicwrites: drop (moved to oe-core)
Signed-off-by: Tim Orling <ticotimo@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-atomicwrites/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-atomicwrites_1.4.0.bb25
2 files changed, 0 insertions, 28 deletions
diff --git a/meta-python/recipes-devtools/python/python3-atomicwrites/run-ptest b/meta-python/recipes-devtools/python/python3-atomicwrites/run-ptest
deleted file mode 100644
index b63c4de0d9..0000000000
--- a/meta-python/recipes-devtools/python/python3-atomicwrites/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-python/recipes-devtools/python/python3-atomicwrites_1.4.0.bb b/meta-python/recipes-devtools/python/python3-atomicwrites_1.4.0.bb
deleted file mode 100644
index 7edd41030f..0000000000
--- a/meta-python/recipes-devtools/python/python3-atomicwrites_1.4.0.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-DESCRIPTION = "Powerful Python library for atomic file writes"
-HOMEPAGE = "https://github.com/untitaker/python-atomicwrites"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=91cc36cfafeefb7863673bcfcb1d4da4"
-
-SRC_URI[md5sum] = "b5cc15c8f9f180a48665f9aacf91d817"
-SRC_URI[sha256sum] = "ae70396ad1a434f9c7046fd2dd196fc04b12f9e91ffb859164193be8b6168a7a"
-
-inherit pypi setuptools3 ptest
-
-SRC_URI += " \
- file://run-ptest \
-"
-
-RDEPENDS_${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
- ${PYTHON_PN}-unixadmin \
-"
-
-do_install_ptest() {
- install -d ${D}${PTEST_PATH}/tests
- cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
-}
-
-RDEPENDS_${PN} = "${PYTHON_PN}-misc"