aboutsummaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-devtools/python
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-01-31 21:11:52 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-02-23 23:21:14 +0100
commit9234bcb0d30e66db7b8fcfd867086185649ecbae (patch)
treefaddf5d0a24254d5e6121f92aa83b901c14ff450 /meta-efl/recipes-devtools/python
parent29a37034c1205cd468815be33c69dcb560e77b67 (diff)
downloadmeta-openembedded-contrib-9234bcb0d30e66db7b8fcfd867086185649ecbae.tar.gz
python-efl: upgrade from separate recipes to shared python-efl-1.8.1
* python-ecore, python-edbus, python-edje, python-elementary, python-emotion, python-evas are now built from single source tree * announcements: 1.8.0: http://sourceforge.net/mailarchive/message.php?msg_id=31728838 1.8.1: http://sourceforge.net/mailarchive/message.php?msg_id=31862842 * be aware that upgrade-path wont probably work correctly and that you have to manually cleanup your sysroots before migrating to new shared efl recipe, for details see https://bugzilla.yoctoproject.org/show_bug.cgi?id=4102 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl/recipes-devtools/python')
-rw-r--r--meta-efl/recipes-devtools/python/python-ecore.inc5
-rw-r--r--meta-efl/recipes-devtools/python/python-ecore_1.7.0.bb5
-rw-r--r--meta-efl/recipes-devtools/python/python-ecore_svn.bb8
-rw-r--r--meta-efl/recipes-devtools/python/python-edbus.inc50
-rw-r--r--meta-efl/recipes-devtools/python/python-edbus_1.7.0.bb3
-rw-r--r--meta-efl/recipes-devtools/python/python-edbus_svn.bb8
-rw-r--r--meta-efl/recipes-devtools/python/python-edje.inc6
-rw-r--r--meta-efl/recipes-devtools/python/python-edje/0001-fix-unicode-conversion.patch38
-rw-r--r--meta-efl/recipes-devtools/python/python-edje_1.7.0.bb6
-rw-r--r--meta-efl/recipes-devtools/python/python-edje_svn.bb10
-rw-r--r--meta-efl/recipes-devtools/python/python-efl.inc36
-rw-r--r--meta-efl/recipes-devtools/python/python-efl_1.8.1.bb4
-rw-r--r--meta-efl/recipes-devtools/python/python-elementary.inc5
-rw-r--r--meta-efl/recipes-devtools/python/python-elementary_1.7.0.bb5
-rw-r--r--meta-efl/recipes-devtools/python/python-elementary_svn.bb8
-rw-r--r--meta-efl/recipes-devtools/python/python-emotion.inc5
-rw-r--r--meta-efl/recipes-devtools/python/python-emotion_1.7.0.bb5
-rw-r--r--meta-efl/recipes-devtools/python/python-emotion_svn.bb8
-rw-r--r--meta-efl/recipes-devtools/python/python-evas.inc4
-rw-r--r--meta-efl/recipes-devtools/python/python-evas_1.7.0.bb5
-rw-r--r--meta-efl/recipes-devtools/python/python-evas_svn.bb8
21 files changed, 63 insertions, 169 deletions
diff --git a/meta-efl/recipes-devtools/python/python-ecore.inc b/meta-efl/recipes-devtools/python/python-ecore.inc
deleted file mode 100644
index 79aaeeccd1..0000000000
--- a/meta-efl/recipes-devtools/python/python-ecore.inc
+++ /dev/null
@@ -1,5 +0,0 @@
-require python-efl.inc
-LICENSE = "LGPLv2.1"
-LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
-DEPENDS += "python-evas ecore"
-RDEPENDS_${PN} += "python-evas"
diff --git a/meta-efl/recipes-devtools/python/python-ecore_1.7.0.bb b/meta-efl/recipes-devtools/python/python-ecore_1.7.0.bb
deleted file mode 100644
index 17b7137171..0000000000
--- a/meta-efl/recipes-devtools/python/python-ecore_1.7.0.bb
+++ /dev/null
@@ -1,5 +0,0 @@
-require ${BPN}.inc
-PR = "${INC_PR}.0"
-
-SRC_URI[md5sum] = "15dd908b71d09ef30f7e758739f3b6fd"
-SRC_URI[sha256sum] = "45d374ffab243b561718897e4eac9aadc1e7ce6e34321a3e728a5f6d07d1e9b6"
diff --git a/meta-efl/recipes-devtools/python/python-ecore_svn.bb b/meta-efl/recipes-devtools/python/python-ecore_svn.bb
deleted file mode 100644
index d551073ce2..0000000000
--- a/meta-efl/recipes-devtools/python/python-ecore_svn.bb
+++ /dev/null
@@ -1,8 +0,0 @@
-require ${BPN}.inc
-PR = "${INC_PR}.0"
-SRCREV = "${EFL_SRCREV}"
-PV = "1.7.0+svnr${SRCPV}"
-DEFAULT_PREFERENCE = "-1"
-
-SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http"
-S = "${WORKDIR}/${SRCNAME}"
diff --git a/meta-efl/recipes-devtools/python/python-edbus.inc b/meta-efl/recipes-devtools/python/python-edbus.inc
index 86ae773436..1d8098f60d 100644
--- a/meta-efl/recipes-devtools/python/python-edbus.inc
+++ b/meta-efl/recipes-devtools/python/python-edbus.inc
@@ -1,6 +1,50 @@
-require python-efl.inc
+DESCRIPTION = "${PN} bindings"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
-DEPENDS += "edbus python-dbus"
-RDEPENDS_${PN} += "python-dbus"
+AUTHOR = "Gustavo Sverzut Barbieri <barbieri@gmail.com>"
+# NOTE: Due to a bug in distutils, even if we don't use pyrex but cython,
+# we need to build pyrex otherwise cython doesn't get called to build
+# the extension modules.
+DEPENDS = "python-cython-native python-pyrex-native python-numeric eina edbus python-dbus"
+RDEPENDS_${PN} += "python-lang python-dbus"
+
+# necessary to let the call for python-config succeed
+export BUILD_SYS
+export HOST_SYS
+
+inherit e-base autotools pkgconfig distutils-base
+
SRCNAME = "python-e_dbus"
+SRCVER = "${PV}"
+
+SRC_URI = "\
+ ${E_MIRROR}/BINDINGS/python/${SRCNAME}-${SRCVER}.tar.bz2 \
+"
+S = "${WORKDIR}/${SRCNAME}-${SRCVER}"
+
+
+do_configure_prepend() {
+ # prefix CYTHON_.*_INCLUDEDIR with path to STAGING_DIR_HOST also use $PKG_CONFIG instead of pkg-config directly
+ sed -i "s#=\`\$PKG_CONFIG --variable=includedir \"python-evas#=${STAGING_DIR_HOST}\`\$PKG_CONFIG --variable=includedir \"python-evas#g" ${S}/configure.ac
+}
+
+do_install_append() {
+ if [ -e examples ]; then
+ for i in `find examples -name "*.edc"`; do
+ cd ${S}/`dirname $i`
+ echo "Generating .edj file for $i..."
+ edje_cc `basename $i`
+ echo "Removing sources in this directory..."
+ rm -f *.edc *.png *.ttf *.jpeg
+ done
+ cd ${S}
+ install -d ${D}${datadir}/${PN}/
+ cp -a examples ${D}${datadir}/${PN}/
+ find ${D}${datadir}/${PN}/examples -name ".svn" | xargs rm -rf
+ fi
+}
+
+FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/*.egg/*/*/.debug"
+
+PACKAGES += "${PN}-examples"
+FILES_${PN}-examples = "${datadir}/${PN}/examples"
diff --git a/meta-efl/recipes-devtools/python/python-edbus_1.7.0.bb b/meta-efl/recipes-devtools/python/python-edbus_1.7.0.bb
index 5628469319..9e5ff0a02f 100644
--- a/meta-efl/recipes-devtools/python/python-edbus_1.7.0.bb
+++ b/meta-efl/recipes-devtools/python/python-edbus_1.7.0.bb
@@ -1,5 +1,6 @@
require ${BPN}.inc
-PR = "${INC_PR}.0"
+
+PR = "r1"
SRC_URI[md5sum] = "40b479444bb06147429a276127981890"
SRC_URI[sha256sum] = "78e5ca334ee25185748660b4e612f984f4d3bced018f062278701429868f117b"
diff --git a/meta-efl/recipes-devtools/python/python-edbus_svn.bb b/meta-efl/recipes-devtools/python/python-edbus_svn.bb
deleted file mode 100644
index d551073ce2..0000000000
--- a/meta-efl/recipes-devtools/python/python-edbus_svn.bb
+++ /dev/null
@@ -1,8 +0,0 @@
-require ${BPN}.inc
-PR = "${INC_PR}.0"
-SRCREV = "${EFL_SRCREV}"
-PV = "1.7.0+svnr${SRCPV}"
-DEFAULT_PREFERENCE = "-1"
-
-SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http"
-S = "${WORKDIR}/${SRCNAME}"
diff --git a/meta-efl/recipes-devtools/python/python-edje.inc b/meta-efl/recipes-devtools/python/python-edje.inc
deleted file mode 100644
index 2e2e1f2b79..0000000000
--- a/meta-efl/recipes-devtools/python/python-edje.inc
+++ /dev/null
@@ -1,6 +0,0 @@
-require python-efl.inc
-LICENSE = "LGPLv2.1"
-LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
-DEPENDS += "edje python-evas evas"
-RDEPENDS_${PN} += "python-evas"
-EXTRA_OECONF += "--disable-examples"
diff --git a/meta-efl/recipes-devtools/python/python-edje/0001-fix-unicode-conversion.patch b/meta-efl/recipes-devtools/python/python-edje/0001-fix-unicode-conversion.patch
deleted file mode 100644
index 3b0cdc627c..0000000000
--- a/meta-efl/recipes-devtools/python/python-edje/0001-fix-unicode-conversion.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From fa12a33b5a3c0e86231ca84967d9eff456e5f314 Mon Sep 17 00:00:00 2001
-From: Jan Luebbe <jluebbe@debian.org>
-Date: Sat, 9 Aug 2008 18:30:04 +0200
-Subject: [PATCH] fix unicode conversion
-
----
- edje/edje.c_edje_object.pxi | 11 +++++++----
- 1 files changed, 7 insertions(+), 4 deletions(-)
-
-diff --git a/edje/edje.c_edje_object.pxi b/edje/edje.c_edje_object.pxi
-index 0f4da68..21c237e 100644
---- a/edje/edje.c_edje_object.pxi
-+++ b/edje/edje.c_edje_object.pxi
-@@ -415,17 +415,20 @@
- else:
- raise TypeError("func must be callable or None")
-
-- def part_text_set(self, char *part, char *text):
-- edje_object_part_text_set(self.obj, part, text)
-+ def part_text_set(self, char *part, text):
-+ cdef char *s
-+ u = text.encode("utf8")
-+ s = u
-+ edje_object_part_text_set(self.obj, part, s)
-
- def part_text_get(self, char *part):
-- "@rtype: str"
-+ "@rtype: unicode"
- cdef const_char_ptr s
- s = edje_object_part_text_get(self.obj, part)
- if s == NULL:
- return None
- else:
-- return s
-+ return s.decode("utf8")
-
- def part_text_select_all(self, char *part):
- edje_object_part_text_select_all(self.obj, part)
diff --git a/meta-efl/recipes-devtools/python/python-edje_1.7.0.bb b/meta-efl/recipes-devtools/python/python-edje_1.7.0.bb
deleted file mode 100644
index 9a30ad435b..0000000000
--- a/meta-efl/recipes-devtools/python/python-edje_1.7.0.bb
+++ /dev/null
@@ -1,6 +0,0 @@
-require ${BPN}.inc
-PR = "${INC_PR}.0"
-SRC_URI += "file://0001-fix-unicode-conversion.patch"
-
-SRC_URI[md5sum] = "1e0d7a4a4504298caaad0cee476e4edb"
-SRC_URI[sha256sum] = "b1eb7be4dea099752c587baa4747d8100de6cead256ffea22a6cc0e88c4e8786"
diff --git a/meta-efl/recipes-devtools/python/python-edje_svn.bb b/meta-efl/recipes-devtools/python/python-edje_svn.bb
deleted file mode 100644
index eca8b7586b..0000000000
--- a/meta-efl/recipes-devtools/python/python-edje_svn.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-require ${BPN}.inc
-PR = "${INC_PR}.0"
-SRCREV = "${EFL_SRCREV}"
-PV = "1.7.0+svnr${SRCPV}"
-DEFAULT_PREFERENCE = "-1"
-
-SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http"
-S = "${WORKDIR}/${SRCNAME}"
-
-SRC_URI += "file://0001-fix-unicode-conversion.patch"
diff --git a/meta-efl/recipes-devtools/python/python-efl.inc b/meta-efl/recipes-devtools/python/python-efl.inc
index b622c40d9f..c608bac7c7 100644
--- a/meta-efl/recipes-devtools/python/python-efl.inc
+++ b/meta-efl/recipes-devtools/python/python-efl.inc
@@ -1,48 +1,32 @@
DESCRIPTION = "${PN} bindings"
-LICENSE = "BSD"
+
+LICENSE = "LGPLv3.0"
+LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=e6a600fd5e1d9cbde2d983680233ad02"
+# there is also GPLv3.0 in COPYING;md5=d32239bcb673463ab874e80d47fae504 but no file seems to use that
+
AUTHOR = "Gustavo Sverzut Barbieri <barbieri@gmail.com>"
# NOTE: Due to a bug in distutils, even if we don't use pyrex but cython,
# we need to build pyrex otherwise cython doesn't get called to build
# the extension modules.
DEPENDS = "python-cython-native python-pyrex-native python-numeric eina"
RDEPENDS_${PN} += "python-lang"
-INC_PR = "r1"
+
+PROVIDES = "python-ecore python-eldbus python-edje python-elementary python-emotion python-evas"
+RPROVIDES_${PN} += "python-ecore python-eldbus python-edje python-elementary python-emotion python-evas"
# necessary to let the call for python-config succeed
export BUILD_SYS
export HOST_SYS
-inherit e-base autotools pkgconfig distutils-base
+inherit e-base distutils pkgconfig
SRCVER = "${PV}"
SRC_URI = "\
- ${E_MIRROR}/BINDINGS/python/${SRCNAME}-${SRCVER}.tar.bz2 \
+ ${E_RELEASES}/bindings/python/${SRCNAME}-${SRCVER}.tar.gz \
"
S = "${WORKDIR}/${SRCNAME}-${SRCVER}"
-
-do_configure_prepend() {
- # prefix CYTHON_.*_INCLUDEDIR with path to STAGING_DIR_HOST also use $PKG_CONFIG instead of pkg-config directly
- sed -i "s#=\`\$PKG_CONFIG --variable=includedir \"python-evas#=${STAGING_DIR_HOST}\`\$PKG_CONFIG --variable=includedir \"python-evas#g" ${S}/configure.ac
-}
-
-do_install_append() {
- if [ -e examples ]; then
- for i in `find examples -name "*.edc"`; do
- cd ${S}/`dirname $i`
- echo "Generating .edj file for $i..."
- edje_cc `basename $i`
- echo "Removing sources in this directory..."
- rm -f *.edc *.png *.ttf *.jpeg
- done
- cd ${S}
- install -d ${D}${datadir}/${PN}/
- cp -a examples ${D}${datadir}/${PN}/
- find ${D}${datadir}/${PN}/examples -name ".svn" | xargs rm -rf
- fi
-}
-
FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/*.egg/*/*/.debug"
PACKAGES += "${PN}-examples"
diff --git a/meta-efl/recipes-devtools/python/python-efl_1.8.1.bb b/meta-efl/recipes-devtools/python/python-efl_1.8.1.bb
new file mode 100644
index 0000000000..15009f6990
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-efl_1.8.1.bb
@@ -0,0 +1,4 @@
+require ${BPN}.inc
+
+SRC_URI[md5sum] = "ca71f501c7e0479f15d2746380b0f81d"
+SRC_URI[sha256sum] = "90ea20d0a90448fd1dcd56210bf34cb9a78905852d83620617bf164f1cef5edc"
diff --git a/meta-efl/recipes-devtools/python/python-elementary.inc b/meta-efl/recipes-devtools/python/python-elementary.inc
deleted file mode 100644
index 3f1d123c3a..0000000000
--- a/meta-efl/recipes-devtools/python/python-elementary.inc
+++ /dev/null
@@ -1,5 +0,0 @@
-require python-efl.inc
-LICENSE = "LGPLv3"
-LIC_FILES_CHKSUM = "file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6"
-DEPENDS += "elementary python-evas"
-RDEPENDS_${PN} += "python-evas python-ecore python-edje"
diff --git a/meta-efl/recipes-devtools/python/python-elementary_1.7.0.bb b/meta-efl/recipes-devtools/python/python-elementary_1.7.0.bb
deleted file mode 100644
index 625c09df29..0000000000
--- a/meta-efl/recipes-devtools/python/python-elementary_1.7.0.bb
+++ /dev/null
@@ -1,5 +0,0 @@
-require ${BPN}.inc
-PR = "${INC_PR}.0"
-
-SRC_URI[md5sum] = "38c8b2ac508ab4e1d12f1557a12169c9"
-SRC_URI[sha256sum] = "63052f8428d725599a0a2765fe48a21e695c66599ec1dcce0a909db440d2216b"
diff --git a/meta-efl/recipes-devtools/python/python-elementary_svn.bb b/meta-efl/recipes-devtools/python/python-elementary_svn.bb
deleted file mode 100644
index d551073ce2..0000000000
--- a/meta-efl/recipes-devtools/python/python-elementary_svn.bb
+++ /dev/null
@@ -1,8 +0,0 @@
-require ${BPN}.inc
-PR = "${INC_PR}.0"
-SRCREV = "${EFL_SRCREV}"
-PV = "1.7.0+svnr${SRCPV}"
-DEFAULT_PREFERENCE = "-1"
-
-SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http"
-S = "${WORKDIR}/${SRCNAME}"
diff --git a/meta-efl/recipes-devtools/python/python-emotion.inc b/meta-efl/recipes-devtools/python/python-emotion.inc
deleted file mode 100644
index ac64676f08..0000000000
--- a/meta-efl/recipes-devtools/python/python-emotion.inc
+++ /dev/null
@@ -1,5 +0,0 @@
-require python-efl.inc
-LICENSE = "LGPLv2.1"
-LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
-DEPENDS += "emotion python-evas"
-RDEPENDS_${PN} += "python-ecore"
diff --git a/meta-efl/recipes-devtools/python/python-emotion_1.7.0.bb b/meta-efl/recipes-devtools/python/python-emotion_1.7.0.bb
deleted file mode 100644
index 01e6751472..0000000000
--- a/meta-efl/recipes-devtools/python/python-emotion_1.7.0.bb
+++ /dev/null
@@ -1,5 +0,0 @@
-require ${BPN}.inc
-PR = "${INC_PR}.0"
-
-SRC_URI[md5sum] = "ac7197ce2617a87fad3dd134a98ad01f"
-SRC_URI[sha256sum] = "ac2910c0e3e861dfc07253b825dc038baa1a3e6ce7d5b362122ad51127e20e91"
diff --git a/meta-efl/recipes-devtools/python/python-emotion_svn.bb b/meta-efl/recipes-devtools/python/python-emotion_svn.bb
deleted file mode 100644
index d551073ce2..0000000000
--- a/meta-efl/recipes-devtools/python/python-emotion_svn.bb
+++ /dev/null
@@ -1,8 +0,0 @@
-require ${BPN}.inc
-PR = "${INC_PR}.0"
-SRCREV = "${EFL_SRCREV}"
-PV = "1.7.0+svnr${SRCPV}"
-DEFAULT_PREFERENCE = "-1"
-
-SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http"
-S = "${WORKDIR}/${SRCNAME}"
diff --git a/meta-efl/recipes-devtools/python/python-evas.inc b/meta-efl/recipes-devtools/python/python-evas.inc
deleted file mode 100644
index 3211b14418..0000000000
--- a/meta-efl/recipes-devtools/python/python-evas.inc
+++ /dev/null
@@ -1,4 +0,0 @@
-require python-efl.inc
-LICENSE = "LGPLv2.1"
-LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
-DEPENDS += "evas"
diff --git a/meta-efl/recipes-devtools/python/python-evas_1.7.0.bb b/meta-efl/recipes-devtools/python/python-evas_1.7.0.bb
deleted file mode 100644
index 62219d8c27..0000000000
--- a/meta-efl/recipes-devtools/python/python-evas_1.7.0.bb
+++ /dev/null
@@ -1,5 +0,0 @@
-require ${BPN}.inc
-PR = "${INC_PR}.0"
-
-SRC_URI[md5sum] = "c3fda2025171f5e3d2bc224e8bae88e5"
-SRC_URI[sha256sum] = "bc00ea23d4d3e9d6448c8a24f918f577cf3c2b25636f36b76b2ed2e3a74d42f5"
diff --git a/meta-efl/recipes-devtools/python/python-evas_svn.bb b/meta-efl/recipes-devtools/python/python-evas_svn.bb
deleted file mode 100644
index d551073ce2..0000000000
--- a/meta-efl/recipes-devtools/python/python-evas_svn.bb
+++ /dev/null
@@ -1,8 +0,0 @@
-require ${BPN}.inc
-PR = "${INC_PR}.0"
-SRCREV = "${EFL_SRCREV}"
-PV = "1.7.0+svnr${SRCPV}"
-DEFAULT_PREFERENCE = "-1"
-
-SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http"
-S = "${WORKDIR}/${SRCNAME}"