aboutsummaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-devtools
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-08-13 15:27:52 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2012-08-20 09:58:08 +0200
commitab19e33a9d9c77074def6e74ac72e84439cd0bee (patch)
tree68e8e91b89418f910ce4c4eff3b20d06ba548871 /meta-efl/recipes-devtools
parent7c28fa0c71de1b487d05695b8401333140bc76b5 (diff)
downloadmeta-openembedded-contrib-ab19e33a9d9c77074def6e74ac72e84439cd0bee.tar.gz
python-efl: introduce recipes for 1.6.99-alpha release and add negative D_P to svn recipes
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl/recipes-devtools')
-rw-r--r--meta-efl/recipes-devtools/python/python-ecore.inc5
-rw-r--r--meta-efl/recipes-devtools/python/python-ecore_1.6.99-alpha.bb6
-rw-r--r--meta-efl/recipes-devtools/python/python-ecore_svn.bb11
-rw-r--r--meta-efl/recipes-devtools/python/python-edbus.inc6
-rw-r--r--meta-efl/recipes-devtools/python/python-edbus_1.6.99-alpha.bb6
-rw-r--r--meta-efl/recipes-devtools/python/python-edbus_svn.bb12
-rw-r--r--meta-efl/recipes-devtools/python/python-edje.inc5
-rw-r--r--meta-efl/recipes-devtools/python/python-edje_1.6.99-alpha.bb7
-rw-r--r--meta-efl/recipes-devtools/python/python-edje_svn.bb11
-rw-r--r--meta-efl/recipes-devtools/python/python-efl.inc9
-rw-r--r--meta-efl/recipes-devtools/python/python-elementary.inc5
-rw-r--r--meta-efl/recipes-devtools/python/python-elementary_1.6.99-alpha.bb6
-rw-r--r--meta-efl/recipes-devtools/python/python-elementary_svn.bb11
-rw-r--r--meta-efl/recipes-devtools/python/python-emotion.inc5
-rw-r--r--meta-efl/recipes-devtools/python/python-emotion_1.6.99-alpha.bb6
-rw-r--r--meta-efl/recipes-devtools/python/python-emotion_svn.bb11
-rw-r--r--meta-efl/recipes-devtools/python/python-evas.inc4
-rw-r--r--meta-efl/recipes-devtools/python/python-evas_1.6.99-alpha.bb6
-rw-r--r--meta-efl/recipes-devtools/python/python-evas_svn.bb10
19 files changed, 109 insertions, 33 deletions
diff --git a/meta-efl/recipes-devtools/python/python-ecore.inc b/meta-efl/recipes-devtools/python/python-ecore.inc
new file mode 100644
index 0000000000..79aaeeccd1
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-ecore.inc
@@ -0,0 +1,5 @@
+require python-efl.inc
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
+DEPENDS += "python-evas ecore"
+RDEPENDS_${PN} += "python-evas"
diff --git a/meta-efl/recipes-devtools/python/python-ecore_1.6.99-alpha.bb b/meta-efl/recipes-devtools/python/python-ecore_1.6.99-alpha.bb
new file mode 100644
index 0000000000..a76c44f5c8
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-ecore_1.6.99-alpha.bb
@@ -0,0 +1,6 @@
+require ${BPN}.inc
+PR = "${INC_PR}.0"
+SRCVER = "1.7.0-alpha"
+
+SRC_URI[md5sum] = "86ba753726881b9bfcaa0fdc0827cd1e"
+SRC_URI[sha256sum] = "b47a155c0bfad6fad68bc0f925c54a8736a61ca72f6a71bd5138ea3298a35c95"
diff --git a/meta-efl/recipes-devtools/python/python-ecore_svn.bb b/meta-efl/recipes-devtools/python/python-ecore_svn.bb
index a6ec5e6045..a0298e8596 100644
--- a/meta-efl/recipes-devtools/python/python-ecore_svn.bb
+++ b/meta-efl/recipes-devtools/python/python-ecore_svn.bb
@@ -1,7 +1,8 @@
-require python-efl.inc
-LICENSE = "LGPLv2.1"
-LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
+require ${BPN}.inc
PR = "${INC_PR}.0"
SRCREV = "${EFL_SRCREV}"
-DEPENDS += "python-evas ecore"
-RDEPENDS_${PN} += "python-evas"
+PV = "1.6.99+svnr${SRCPV}"
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http"
+S = "${WORKDIR}/${SRCNAME}"
diff --git a/meta-efl/recipes-devtools/python/python-edbus.inc b/meta-efl/recipes-devtools/python/python-edbus.inc
new file mode 100644
index 0000000000..86ae773436
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-edbus.inc
@@ -0,0 +1,6 @@
+require python-efl.inc
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
+DEPENDS += "edbus python-dbus"
+RDEPENDS_${PN} += "python-dbus"
+SRCNAME = "python-e_dbus"
diff --git a/meta-efl/recipes-devtools/python/python-edbus_1.6.99-alpha.bb b/meta-efl/recipes-devtools/python/python-edbus_1.6.99-alpha.bb
new file mode 100644
index 0000000000..c643141efc
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-edbus_1.6.99-alpha.bb
@@ -0,0 +1,6 @@
+require ${BPN}.inc
+PR = "${INC_PR}.0"
+SRCVER = "1.7.0-alpha"
+
+SRC_URI[md5sum] = "bd68e260e1a23fc14313afa48e70bebd"
+SRC_URI[sha256sum] = "63e823c8366f293db1940524ac76d6f91109a7202cf38ad6407d414d15e09aca"
diff --git a/meta-efl/recipes-devtools/python/python-edbus_svn.bb b/meta-efl/recipes-devtools/python/python-edbus_svn.bb
index 518f7c2102..a0298e8596 100644
--- a/meta-efl/recipes-devtools/python/python-edbus_svn.bb
+++ b/meta-efl/recipes-devtools/python/python-edbus_svn.bb
@@ -1,8 +1,8 @@
-require python-efl.inc
-LICENSE = "LGPLv2.1"
-LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
+require ${BPN}.inc
PR = "${INC_PR}.0"
SRCREV = "${EFL_SRCREV}"
-DEPENDS += "edbus python-dbus"
-RDEPENDS_${PN} += "python-dbus"
-SRCNAME = "python-e_dbus"
+PV = "1.6.99+svnr${SRCPV}"
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http"
+S = "${WORKDIR}/${SRCNAME}"
diff --git a/meta-efl/recipes-devtools/python/python-edje.inc b/meta-efl/recipes-devtools/python/python-edje.inc
new file mode 100644
index 0000000000..473b92e873
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-edje.inc
@@ -0,0 +1,5 @@
+require python-efl.inc
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
+DEPENDS += "edje python-evas evas"
+RDEPENDS_${PN} += "python-evas"
diff --git a/meta-efl/recipes-devtools/python/python-edje_1.6.99-alpha.bb b/meta-efl/recipes-devtools/python/python-edje_1.6.99-alpha.bb
new file mode 100644
index 0000000000..1d7bb069fe
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-edje_1.6.99-alpha.bb
@@ -0,0 +1,7 @@
+require ${BPN}.inc
+PR = "${INC_PR}.0"
+SRCVER = "1.7.0-alpha"
+SRC_URI += "file://0001-fix-unicode-conversion.patch"
+
+SRC_URI[md5sum] = "fbe5105abb5b2d3de71302ff3973945a"
+SRC_URI[sha256sum] = "f5004d9b784b0ca37436daacff7f4f21bb3094b9fdfc5abc95f8e57e90ecb242"
diff --git a/meta-efl/recipes-devtools/python/python-edje_svn.bb b/meta-efl/recipes-devtools/python/python-edje_svn.bb
index a6b376c2c2..3d392d0ff8 100644
--- a/meta-efl/recipes-devtools/python/python-edje_svn.bb
+++ b/meta-efl/recipes-devtools/python/python-edje_svn.bb
@@ -1,9 +1,10 @@
-require python-efl.inc
-LICENSE = "LGPLv2.1"
-LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
+require ${BPN}.inc
PR = "${INC_PR}.0"
SRCREV = "${EFL_SRCREV}"
-DEPENDS += "edje python-evas evas"
-RDEPENDS_${PN} += "python-evas"
+PV = "1.6.99+svnr${SRCPV}"
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http"
+S = "${WORKDIR}/${SRCNAME}"
SRC_URI += "file://0001-fix-unicode-conversion.patch"
diff --git a/meta-efl/recipes-devtools/python/python-efl.inc b/meta-efl/recipes-devtools/python/python-efl.inc
index 498c3be65e..77d4114ca7 100644
--- a/meta-efl/recipes-devtools/python/python-efl.inc
+++ b/meta-efl/recipes-devtools/python/python-efl.inc
@@ -6,7 +6,6 @@ AUTHOR = "Gustavo Sverzut Barbieri <barbieri@gmail.com>"
# the extension modules.
DEPENDS = "python-cython-native python-pyrex-native python-numeric eina"
RDEPENDS_${PN} += "python-lang"
-PV = "1.6.99+svnr${SRCPV}"
INC_PR = "r0"
# necessary to let the call for python-config succeed
@@ -15,8 +14,12 @@ export HOST_SYS
inherit e-base autotools pkgconfig distutils-base
-SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http"
-S = "${WORKDIR}/${SRCNAME}"
+SRCVER = "${PV}"
+
+SRC_URI = "\
+ ${E_MIRROR}/BINDINGS/python/${SRCNAME}-${SRCVER}.tar.bz2 \
+"
+S = "${WORKDIR}/${SRCNAME}-${SRCVER}"
do_configure_prepend() {
diff --git a/meta-efl/recipes-devtools/python/python-elementary.inc b/meta-efl/recipes-devtools/python/python-elementary.inc
new file mode 100644
index 0000000000..3f1d123c3a
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-elementary.inc
@@ -0,0 +1,5 @@
+require python-efl.inc
+LICENSE = "LGPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6"
+DEPENDS += "elementary python-evas"
+RDEPENDS_${PN} += "python-evas python-ecore python-edje"
diff --git a/meta-efl/recipes-devtools/python/python-elementary_1.6.99-alpha.bb b/meta-efl/recipes-devtools/python/python-elementary_1.6.99-alpha.bb
new file mode 100644
index 0000000000..8ed363e507
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-elementary_1.6.99-alpha.bb
@@ -0,0 +1,6 @@
+require ${BPN}.inc
+PR = "${INC_PR}.0"
+SRCVER = "1.7.0-alpha"
+
+SRC_URI[md5sum] = "bad3bd52e79aeea1ee9ffa0ab8a54855"
+SRC_URI[sha256sum] = "32ded2fb4e66aa543ae9274076d031f8465167a0cc1af3fcd26bcda85b2e7094"
diff --git a/meta-efl/recipes-devtools/python/python-elementary_svn.bb b/meta-efl/recipes-devtools/python/python-elementary_svn.bb
index ffb6d5e7c5..a0298e8596 100644
--- a/meta-efl/recipes-devtools/python/python-elementary_svn.bb
+++ b/meta-efl/recipes-devtools/python/python-elementary_svn.bb
@@ -1,7 +1,8 @@
-require python-efl.inc
-LICENSE = "LGPLv3"
-LIC_FILES_CHKSUM = "file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6"
+require ${BPN}.inc
PR = "${INC_PR}.0"
SRCREV = "${EFL_SRCREV}"
-DEPENDS += "elementary python-evas"
-RDEPENDS_${PN} += "python-evas python-ecore python-edje"
+PV = "1.6.99+svnr${SRCPV}"
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http"
+S = "${WORKDIR}/${SRCNAME}"
diff --git a/meta-efl/recipes-devtools/python/python-emotion.inc b/meta-efl/recipes-devtools/python/python-emotion.inc
new file mode 100644
index 0000000000..ac64676f08
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-emotion.inc
@@ -0,0 +1,5 @@
+require python-efl.inc
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
+DEPENDS += "emotion python-evas"
+RDEPENDS_${PN} += "python-ecore"
diff --git a/meta-efl/recipes-devtools/python/python-emotion_1.6.99-alpha.bb b/meta-efl/recipes-devtools/python/python-emotion_1.6.99-alpha.bb
new file mode 100644
index 0000000000..a2ad303771
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-emotion_1.6.99-alpha.bb
@@ -0,0 +1,6 @@
+require ${BPN}.inc
+PR = "${INC_PR}.0"
+SRCVER = "1.7.0-alpha"
+
+SRC_URI[md5sum] = "34249ce9ee6602205ede16e311c2712c"
+SRC_URI[sha256sum] = "f121a801c213d5014cde17df49107407bd60be362f98bab3530c14c9c8a54e03"
diff --git a/meta-efl/recipes-devtools/python/python-emotion_svn.bb b/meta-efl/recipes-devtools/python/python-emotion_svn.bb
index 89002c3b71..a0298e8596 100644
--- a/meta-efl/recipes-devtools/python/python-emotion_svn.bb
+++ b/meta-efl/recipes-devtools/python/python-emotion_svn.bb
@@ -1,7 +1,8 @@
-require python-efl.inc
-LICENSE = "LGPLv2.1"
-LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
+require ${BPN}.inc
PR = "${INC_PR}.0"
SRCREV = "${EFL_SRCREV}"
-DEPENDS += "emotion python-evas"
-RDEPENDS_${PN} += "python-ecore"
+PV = "1.6.99+svnr${SRCPV}"
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http"
+S = "${WORKDIR}/${SRCNAME}"
diff --git a/meta-efl/recipes-devtools/python/python-evas.inc b/meta-efl/recipes-devtools/python/python-evas.inc
new file mode 100644
index 0000000000..3211b14418
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-evas.inc
@@ -0,0 +1,4 @@
+require python-efl.inc
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
+DEPENDS += "evas"
diff --git a/meta-efl/recipes-devtools/python/python-evas_1.6.99-alpha.bb b/meta-efl/recipes-devtools/python/python-evas_1.6.99-alpha.bb
new file mode 100644
index 0000000000..8fa82dad5f
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-evas_1.6.99-alpha.bb
@@ -0,0 +1,6 @@
+require ${BPN}.inc
+PR = "${INC_PR}.0"
+SRCVER = "1.7.0-alpha"
+
+SRC_URI[md5sum] = "c3e02d8e897508db2d6365dc3b83ae20"
+SRC_URI[sha256sum] = "5af43a770e0edaf01c679c8eaecef38c747c8801980f1d9423d040cf36220d76"
diff --git a/meta-efl/recipes-devtools/python/python-evas_svn.bb b/meta-efl/recipes-devtools/python/python-evas_svn.bb
index 79844beb58..a0298e8596 100644
--- a/meta-efl/recipes-devtools/python/python-evas_svn.bb
+++ b/meta-efl/recipes-devtools/python/python-evas_svn.bb
@@ -1,6 +1,8 @@
-require python-efl.inc
-LICENSE = "LGPLv2.1"
-LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
+require ${BPN}.inc
PR = "${INC_PR}.0"
SRCREV = "${EFL_SRCREV}"
-DEPENDS += "evas"
+PV = "1.6.99+svnr${SRCPV}"
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http"
+S = "${WORKDIR}/${SRCNAME}"