aboutsummaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-efl/efl
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-04-09 09:15:23 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-04-13 12:55:52 +0200
commit539922a6ddb35fb6fef3b754b4999fae61470681 (patch)
tree6cfab8f9e937eff5090c3b64fec9cdaac7ce301b /meta-efl/recipes-efl/efl
parent932146a33175f14fda42899edf78fb31228062e5 (diff)
downloadmeta-openembedded-contrib-539922a6ddb35fb6fef3b754b4999fae61470681.tar.gz
efl,elementary,evas-generic-loaders: upgrade to 1.13.2
* announcements: https://phab.enlightenment.org/phame/live/3/post/efl_and_elementary_1_13_1_release/ https://phab.enlightenment.org/phame/live/3/post/efl_elementary_and_evas_generic_loaders_1_13_2_release/ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl/recipes-efl/efl')
-rw-r--r--meta-efl/recipes-efl/efl/efl.inc7
-rw-r--r--meta-efl/recipes-efl/efl/efl/0003-edje_cc-Avoid-segfault-when-strcmp-NULL-items.patch30
-rw-r--r--meta-efl/recipes-efl/efl/efl_1.13.2.bb (renamed from meta-efl/recipes-efl/efl/efl_1.13.0.bb)5
-rw-r--r--meta-efl/recipes-efl/efl/elementary_1.13.2.bb (renamed from meta-efl/recipes-efl/efl/elementary_1.13.0.bb)4
-rw-r--r--meta-efl/recipes-efl/efl/evas-generic-loaders_1.13.0.bb8
-rw-r--r--meta-efl/recipes-efl/efl/evas-generic-loaders_1.13.2.bb8
6 files changed, 18 insertions, 44 deletions
diff --git a/meta-efl/recipes-efl/efl/efl.inc b/meta-efl/recipes-efl/efl/efl.inc
index b765bf0d09..ba993af35c 100644
--- a/meta-efl/recipes-efl/efl/efl.inc
+++ b/meta-efl/recipes-efl/efl/efl.inc
@@ -3,7 +3,7 @@ LICENSE = "MIT & BSD & LGPL-2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=a1809a807e39dd48ddcf7be98477d130"
DEPENDS_class-native = "freetype-native libxext-native libpng-native jpeg-native tiff-native libfribidi-native glib-2.0-native dbus-native"
-DEPENDS = "virtual/libiconv tslib curl glib-2.0 gnutls pkgconfig zlib jpeg openssl libsndfile1 dbus libexif librsvg freetype libpng tiff libxext virtual/libx11 libxdamage libxrender fontconfig libfribidi giflib udev libxcursor libxcomposite libxinerama libxrandr libxtst libxscrnsaver efl-native"
+DEPENDS = "virtual/libiconv tslib curl glib-2.0 gnutls pkgconfig zlib jpeg openssl libsndfile1 dbus libexif librsvg freetype libpng tiff libxext virtual/libx11 libxdamage libxrender fontconfig libfribidi giflib udev libxcursor libxcomposite libxinerama libxrandr libxtst libxscrnsaver efl-native util-linux"
inherit efl gettext pkgconfig
@@ -75,6 +75,11 @@ do_configure_prepend_class-native() {
sed -i 's/EFL_LIB_START_OPTIONAL(\[Eeze\], \[test "${have_linux}" = "yes"\])/EFL_LIB_START_OPTIONAL([Eeze], [test "${no-we-really-dont-want-native-eeze}" = "yes"])/g' ${S}/configure.ac
}
+do_install_append() {
+ # don't ship precompiled lua files
+ rm -f ${datadir}/elua/*/*.luac
+}
+
PACKAGES =+ "edje-utils embryo-utils embryo-tests efreet-trash efreet-mime libeet libefreet ecore-audio ecore-input-evas ecore-input ecore-imf-evas ecore-imf ecore-file ecore-con ecore-ipc ecore-x ecore-evas libemotion eo ecore edje eet eeze efreet eina eio embryo emotion ethumb evas eldbus elua"
# upgrade path from 1.7
diff --git a/meta-efl/recipes-efl/efl/efl/0003-edje_cc-Avoid-segfault-when-strcmp-NULL-items.patch b/meta-efl/recipes-efl/efl/efl/0003-edje_cc-Avoid-segfault-when-strcmp-NULL-items.patch
deleted file mode 100644
index 55d7b543c8..0000000000
--- a/meta-efl/recipes-efl/efl/efl/0003-edje_cc-Avoid-segfault-when-strcmp-NULL-items.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 84259714c2376fdb919299e8e01af1ccc6fbe2c0 Mon Sep 17 00:00:00 2001
-From: Stefan Schmidt <s.schmidt@samsung.com>
-Date: Thu, 12 Feb 2015 15:24:27 +0100
-Subject: [PATCH 3/3] edje_cc: Avoid segfault when strcmp NULL items
-
-Martin reported a porblem with one of the SHR project edc files after an upgrade
-to 1.13. The segfault itself is easy enough to fix here but I think there might
-be other problems with the edc after this segfault is gone. We will see.
-
-Fixes T2106
----
- src/bin/edje/edje_cc_out.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/bin/edje/edje_cc_out.c b/src/bin/edje/edje_cc_out.c
-index 4f582c7..bc85444 100755
---- a/src/bin/edje/edje_cc_out.c
-+++ b/src/bin/edje/edje_cc_out.c
-@@ -386,7 +386,7 @@ check_source_links(Edje_Part_Collection *pc, Edje_Part *ep, Eet_File *ef, Eina_L
- EINA_LIST_FOREACH(edje_collections, l, pc_source)
- {
- /* Find sourced group */
-- if (strcmp(ep->source, pc_source->part) == 0)
-+ if (ep->source && pc_source->part && strcmp(ep->source, pc_source->part) == 0)
- {
- /* Go through every part to find parts with type GROUP */
- for (i = 0; i < pc_source->parts_count; ++i)
---
-2.3.0
-
diff --git a/meta-efl/recipes-efl/efl/efl_1.13.0.bb b/meta-efl/recipes-efl/efl/efl_1.13.2.bb
index b243b817e4..176f58aeb2 100644
--- a/meta-efl/recipes-efl/efl/efl_1.13.0.bb
+++ b/meta-efl/recipes-efl/efl/efl_1.13.2.bb
@@ -4,11 +4,10 @@ SRC_URI = "\
${E_RELEASES}/libs/${SRCNAME}/${SRCNAME}-${SRCVER}.tar.gz \
file://0001-configure.ac-Don-t-check-for-Xprint-extension.patch \
file://0002-evas_3d-Add-Eet.h-includes.patch \
- file://0003-edje_cc-Avoid-segfault-when-strcmp-NULL-items.patch \
"
-SRC_URI[md5sum] = "c73f00e1e25b3b660e15ef754c76541d"
-SRC_URI[sha256sum] = "7ff797d4cd01143edc1258a287be3ddfb11264f0b855878d8f5ad5129dee9357"
+SRC_URI[md5sum] = "dd779050ccc4ad8d7ae71f2dc8c85855"
+SRC_URI[sha256sum] = "98404d8de63eea318f748c25708ec989628f025adf12cd54697e5de2fe48c2a4"
# Temporary disable until error like the one following are fixed
# efl-native/2_1.8.4-r0/efl-1.8.4/src/lib/eet/.libs/libeet.so: file not recognized: File truncated
diff --git a/meta-efl/recipes-efl/efl/elementary_1.13.0.bb b/meta-efl/recipes-efl/efl/elementary_1.13.2.bb
index e7be246c87..db6afdef24 100644
--- a/meta-efl/recipes-efl/efl/elementary_1.13.0.bb
+++ b/meta-efl/recipes-efl/efl/elementary_1.13.2.bb
@@ -8,8 +8,8 @@ SRC_URI = "\
# these paths aren't passed in -native build
SRC_URI_append_class-target = " file://0001-Makefile-Use-elementary_codegen-defined-in-configure.patch"
-SRC_URI[md5sum] = "e8464cc2d89585cfe189584c7081845b"
-SRC_URI[sha256sum] = "52f1b4304f22156ab53d2d13b8d8f15c58a110a3bc3f31a13fc357eb9527778c"
+SRC_URI[md5sum] = "0d32d241af1c96c06da6d130020275f0"
+SRC_URI[sha256sum] = "312dd63f3c82c9076f0cfe5125990e650d7767a776186631455911a980f91039"
# autotools-brokensep - configure updates Elementary.h correctly in ${B}, but then build is using Elementary.h from ${S}
# which includes #define ELM_EMAP (instead of #undef ELM_EMAP) and building fails
diff --git a/meta-efl/recipes-efl/efl/evas-generic-loaders_1.13.0.bb b/meta-efl/recipes-efl/efl/evas-generic-loaders_1.13.0.bb
deleted file mode 100644
index cae8df70f3..0000000000
--- a/meta-efl/recipes-efl/efl/evas-generic-loaders_1.13.0.bb
+++ /dev/null
@@ -1,8 +0,0 @@
-require ${BPN}.inc
-
-SRC_URI = "\
- ${E_RELEASES}/libs/${SRCNAME}/${SRCNAME}-${SRCVER}.tar.gz \
-"
-
-SRC_URI[md5sum] = "45df9e4816ceba40219db0167c549e1e"
-SRC_URI[sha256sum] = "c3bcb7d418b8cea79bbaf0731d008e527697b44239ff6b69064df785ca94df9b"
diff --git a/meta-efl/recipes-efl/efl/evas-generic-loaders_1.13.2.bb b/meta-efl/recipes-efl/efl/evas-generic-loaders_1.13.2.bb
new file mode 100644
index 0000000000..162a85b0e0
--- /dev/null
+++ b/meta-efl/recipes-efl/efl/evas-generic-loaders_1.13.2.bb
@@ -0,0 +1,8 @@
+require ${BPN}.inc
+
+SRC_URI = "\
+ ${E_RELEASES}/libs/${SRCNAME}/${SRCNAME}-${SRCVER}.tar.gz \
+"
+
+SRC_URI[md5sum] = "b1e3401429b7dadbf70e9472d25c9986"
+SRC_URI[sha256sum] = "8455f10b8dd418eaa4d64d3eb6446814d893d96ff083646afbdbdf8626baa81a"