aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorNaresh Bhat <naresh.bhat@linaro.org>2015-06-03 14:54:32 +0530
committerMartin Jansa <Martin.Jansa@gmail.com>2015-06-08 14:15:24 +0200
commitf93e248753fc70fca5fa9c75d9ea66b8ca762974 (patch)
tree4c9130a292df68caa12b8f45cd1f8bfad2b09dca /meta-filesystems
parent7db802aa7f1440e78c179984cf621bdeea7d6264 (diff)
downloadmeta-openembedded-contrib-f93e248753fc70fca5fa9c75d9ea66b8ca762974.tar.gz
xorriso: Add xorriso v1.4.0
Add xorriso v1.4.0 based on the discussions http://patchwork.openembedded.org/patch/91143/ http://lists.openembedded.org/pipermail/openembedded-devel/2015-April/100981.html We have tested this package with Montavista CGE product - http://www.mvista.com/ and luvOS distribution - https://01.org/linux-uefi-validation build. Inherit the pkgconfig to avoid the below error, .. ... | disabled use of O_DIRECT with input of -as cdrskin | luv-yocto/build/tmp/work/aarch64-oe-linux/xorriso/1.4.0-r0/xorriso-1.4.0/ configure: line 14352: syntax error near unexpected token `LIBCDIO,' | luv-yocto/build/tmp/work/aarch64-oe-linux/xorriso/1.4.0-r0/xorriso-1.4.0/ configure: line 14352: ` PKG_CHECK_MODULES(LIBCDIO, libcdio >= $LIBCDIO_REQUIRED)' ... .... Signed-off-by: Naresh Bhat <naresh.bhat@linaro.org> Signed-off-by: Jagadeesh Krishnanjanappa <jkrishnanjanappa@mvista.com> Signed-off-by: Gaurang Shastri <gshastri@juniper.net> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-utils/xorriso/xorriso_1.4.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-utils/xorriso/xorriso_1.4.0.bb b/meta-filesystems/recipes-utils/xorriso/xorriso_1.4.0.bb
new file mode 100644
index 0000000000..8b181ca321
--- /dev/null
+++ b/meta-filesystems/recipes-utils/xorriso/xorriso_1.4.0.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "xorriso copies file objects from POSIX compliant filesystems \
+into Rock Ridge enhanced ISO 9660 filesystems and allows session-wise \
+manipulation of such filesystems"
+
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+SRC_URI = "http://www.gnu.org/software/${BPN}/${BPN}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "ec79fd2736b8da76e7a870e27cadf6fa"
+SRC_URI[sha256sum] = "0bd1e085015b28c24f57697d6def2fe84517967dc417554c0c3ccf1685ed0e56"
+
+PACKAGECONFIG ??= "acl attr zlib bzip2 readline"
+PACKAGECONFIG[acl] = "--enable-libacl,--disable-libacl,acl,"
+PACKAGECONFIG[attr] = "--enable-xattr,--disable-xattr,attr,"
+PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
+PACKAGECONFIG[bzip2] = "--enable-libbz2,--disable-libbz2,bzip2,"
+PACKAGECONFIG[readline] = "--enable-libreadline,--disable-libreadline,readline,"
+
+inherit autotools-brokensep pkgconfig
+
+do_configure_prepend () {
+ touch NEWS
+}
+
+RDEPENDS_${PN} = "tk"
+REQUIRED_DISTRO_FEATURES = "x11"
+
+BBCLASSEXTEND = "native"