aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-02-01 14:23:40 +0000
committerArmin Kuster <akuster808@gmail.com>2018-02-11 12:01:54 -0800
commit69fdb96e9b41ac5211ed9b21d2249202fd0853a8 (patch)
treea01fe6880765cdb89a47acca5babf17294e0d92b /meta-filesystems
parentcf4161777141c20a811113a5ad3216248bfa6412 (diff)
downloadmeta-openembedded-contrib-69fdb96e9b41ac5211ed9b21d2249202fd0853a8.tar.gz
samba, openwsman, pam-ssh-agent-auth, sblim-sfcb, passwdqc, python-pam, smbnetfs: require pam in DISTRO_FEATURES
* there is explicit dependency on libpam without respecting pam in DISTRO_FEATURES so add the check to prevent people building it against broken libpam Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs_git.bb b/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs_git.bb
index fefc045386..c72936c087 100644
--- a/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs_git.bb
+++ b/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs_git.bb
@@ -11,6 +11,10 @@ HOMEPAGE ="http://sourceforge.net/projects/smbnetfs"
DEPENDS = "fuse samba"
DEPENDS_append_libc-musl = " libexecinfo"
+# samba depends on libpam
+inherit distro_features_check
+REQUIRED_DISTRO_FEATURES = "pam"
+
inherit autotools gitpkgv pkgconfig
PKGV = "${GITPKGVTAG}"