aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-10-28 13:49:59 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-10-28 14:32:06 +0000
commit3a30c562385cb3d9cd1b3043f6fe677a22024018 (patch)
tree66dc67f338ba316c25ca672950ef334e9e357386 /meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb
parentd66c9a8b625f7b19f7b17e728dc82413399c2e19 (diff)
downloadmeta-openembedded-contrib-3a30c562385cb3d9cd1b3043f6fe677a22024018.tar.gz
Replace bb.data.* with d.*
Used sed expression given here: http://lists.linuxtogo.org/pipermail/openembedded-core/2011-November/012373.html Plus an additional expression for .expand. Full expression is: sed \ -e 's:bb.data.\(setVar([^,]*,[^,]*\), \([^ )]*\) *):\2.\1):g' \ -e 's:bb.data.\(setVarFlag([^,]*,[^,]*,[^,]*\), \([^) ]*\) *):\2.\1):g' \ -e 's:bb.data.\(getVar([^,]*\), \([^, ]*\) *,\([^)]*\)):\2.\1,\3):g' \ -e 's:bb.data.\(getVarFlag([^,]*,[^,]*\), \([^, ]*\) *,\([^)]*\)):\2.\1,\3):g' \ -e 's:bb.data.\(getVarFlag([^,]*,[^,]*\), \([^) ]*\) *):\2.\1):g' \ -e 's:bb.data.\(getVar([^,]*\), \([^) ]*\) *):\2.\1):g' \ -e 's:bb.data.\(expand([^,]*\), \([^ )]*\) *):\2.\1):g' \ -i `grep -ril bb.data *` Some minor correction in systemd.bbclass was needed for some expressions that didn't quite match the regex in the desired way; additionally a few instances were manually changed. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb')
-rw-r--r--meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb b/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb
index 46be86fce8..531a2d7b15 100644
--- a/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb
+++ b/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb
@@ -43,8 +43,8 @@ FILES_${PN}-doc += " ${datadir}/gtk-doc"
PACKAGES_DYNAMIC += "^gnome-vfs-plugin-.*"
python populate_packages_prepend () {
- print bb.data.getVar('FILES_gnome-vfs', d, 1)
+ print d.getVar('FILES_gnome-vfs', 1)
- plugindir = bb.data.expand('${libdir}/gnome-vfs-2.0/modules/', d)
+ plugindir = d.expand('${libdir}/gnome-vfs-2.0/modules/')
do_split_packages(d, plugindir, '^lib(.*)\.so$', 'gnome-vfs-plugin-%s', 'GNOME VFS plugin for %s')
}