aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/libgnome
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-04-29 14:22:37 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-05-03 13:32:04 +0200
commit68ce4c403611fbb89865e6dabaf56d1d0d39e97b (patch)
tree32d0b3d65e8d6a914d1bfe50f3e5dcea1d6b524b /meta-gnome/recipes-gnome/libgnome
parent376a5b381f597dd87eb20d685b0f0f26f6347135 (diff)
downloadmeta-openembedded-contrib-68ce4c403611fbb89865e6dabaf56d1d0d39e97b.tar.gz
libgnome: fix compile
error message was: | gnome-program.c: In function 'gnome_program_init_common': | gnome-program.c:2067:2: error: implicit declaration of function 'g_atexit' [-Werror=implicit-function-declaration] Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/libgnome')
-rw-r--r--meta-gnome/recipes-gnome/libgnome/libgnome/0001-libgnome-Makefile.am-allow-deprecated-symbols.patch35
-rw-r--r--meta-gnome/recipes-gnome/libgnome/libgnome_2.32.1.bb3
2 files changed, 37 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/libgnome/libgnome/0001-libgnome-Makefile.am-allow-deprecated-symbols.patch b/meta-gnome/recipes-gnome/libgnome/libgnome/0001-libgnome-Makefile.am-allow-deprecated-symbols.patch
new file mode 100644
index 0000000000..b6583034f2
--- /dev/null
+++ b/meta-gnome/recipes-gnome/libgnome/libgnome/0001-libgnome-Makefile.am-allow-deprecated-symbols.patch
@@ -0,0 +1,35 @@
+From ce1cd20fceea7dbcc5b983d94de771461eccf7cf Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
+Date: Mon, 29 Apr 2013 14:17:13 +0200
+Subject: [PATCH] libgnome/Makefile.am: allow deprecated symbols
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+fixes:
+
+| gnome-program.c: In function 'gnome_program_init_common':
+| gnome-program.c:2067:2: error: implicit declaration of function 'g_atexit' [-Werror=implicit-function-declaration]
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
+---
+ libgnome/Makefile.am | 1 -
+ 1 files changed, 0 insertions(+), 1 deletions(-)
+
+diff --git a/libgnome/Makefile.am b/libgnome/Makefile.am
+index 9c8cd3e..aa01f6c 100644
+--- a/libgnome/Makefile.am
++++ b/libgnome/Makefile.am
+@@ -17,7 +17,6 @@ INCLUDES = \
+ -I$(srcdir)/.. \
+ $(WARN_CFLAGS) \
+ $(LIBGNOME_CFLAGS) \
+- -DG_DISABLE_DEPRECATED \
+ -DLIBGNOME_PREFIX=\""$(prefix)"\" \
+ -DLIBGNOME_LIBDIR=\""$(libdir)"\" \
+ -DLIBGNOME_DATADIR=\""$(datadir)"\" \
+--
+1.7.6.5
+
diff --git a/meta-gnome/recipes-gnome/libgnome/libgnome_2.32.1.bb b/meta-gnome/recipes-gnome/libgnome/libgnome_2.32.1.bb
index 08139735ae..325912f438 100644
--- a/meta-gnome/recipes-gnome/libgnome/libgnome_2.32.1.bb
+++ b/meta-gnome/recipes-gnome/libgnome/libgnome_2.32.1.bb
@@ -5,10 +5,11 @@ SECTION = "x11/gnome/libs"
inherit gnome lib_package
-PR = "r1"
+PR = "r2"
SRC_URI[archive.md5sum] = "a4345e6087ae6195d65a4674ffdca559"
SRC_URI[archive.sha256sum] = "b2c63916866485793b87398266dd7778548c1734923c272a94d84ee011b6f7a4"
+SRC_URI += "file://0001-libgnome-Makefile.am-allow-deprecated-symbols.patch"
DEPENDS += "libcanberra gconf-native gnome-vfs libbonobo esound"