aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/yelp/yelp_3.34.0.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2019-10-25 09:21:06 +0200
committerKhem Raj <raj.khem@gmail.com>2019-10-25 10:42:44 -0700
commitfbd3f30b7d635eda9737b9e525b1d39da3184649 (patch)
tree29ab0a6ef7f76769e140ab8119c2871d9aa017bb /meta-gnome/recipes-gnome/yelp/yelp_3.34.0.bb
parent1ed7458f233dabd3679626b2803ae83888ede6e7 (diff)
downloadmeta-openembedded-contrib-fbd3f30b7d635eda9737b9e525b1d39da3184649.tar.gz
yelp: initial add 3.34.0
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/yelp/yelp_3.34.0.bb')
-rw-r--r--meta-gnome/recipes-gnome/yelp/yelp_3.34.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/yelp/yelp_3.34.0.bb b/meta-gnome/recipes-gnome/yelp/yelp_3.34.0.bb
new file mode 100644
index 0000000000..13c4e52bf3
--- /dev/null
+++ b/meta-gnome/recipes-gnome/yelp/yelp_3.34.0.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Help browser for the GNOME desktop"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = " \
+ file://COPYING;md5=6e1b9cb787e76d7e6946887a65caa754 \
+"
+
+inherit gnomebase autotools-brokensep gsettings gettext gtk-doc
+
+SRC_URI[archive.md5sum] = "776e29bd16424c8712cbf340cfe6429b"
+SRC_URI[archive.sha256sum] = "e3d6527c5963d73206891b32f1f23363164be57de248555513bd0be77a7bd045"
+
+DEPENDS += " \
+ libxml2-native \
+ glib-2.0-native \
+ itstool-native \
+ gtk+3 \
+ appstream-glib \
+ libxslt \
+ sqlite3 \
+ webkitgtk \
+ yelp-xsl \
+"
+
+do_configure_prepend() {
+ export ITSTOOL=${STAGING_BINDIR_NATIVE}/itstool
+}
+
+FILES_${PN} += " \
+ ${datadir}/metainfo \
+ ${datadir}/yelp-xsl \
+"
+
+RDEPENDS_${PN} += "yelp-xsl"