aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-03-07 17:21:02 -0800
committerKhem Raj <raj.khem@gmail.com>2024-03-08 10:07:28 -0800
commitd8511c2432ca4ba75bca6e7f71f3c4c3f6098aae (patch)
tree9d2c3df79c610af475c5532e230e2e67c8612321 /meta-gnome
parenta60e2b87ca34a1bf6df8bcef4f0cd34b3a40d8cd (diff)
downloadmeta-openembedded-contrib-d8511c2432ca4ba75bca6e7f71f3c4c3f6098aae.tar.gz
gnome-commander: Fix build with taglib 2.0
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gnome-commander/gnome-commander/0001-Build-fix-needed-with-taglib-2.0.patch37
-rw-r--r--meta-gnome/recipes-gnome/gnome-commander/gnome-commander_1.16.1.bb1
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-commander/gnome-commander/0001-Build-fix-needed-with-taglib-2.0.patch b/meta-gnome/recipes-gnome/gnome-commander/gnome-commander/0001-Build-fix-needed-with-taglib-2.0.patch
new file mode 100644
index 0000000000..8f6920c2cc
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-commander/gnome-commander/0001-Build-fix-needed-with-taglib-2.0.patch
@@ -0,0 +1,37 @@
+From dc3aa0ff5a41114b17816f1f36f6bb5631c6ab5c Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 7 Mar 2024 17:17:29 -0800
+Subject: [PATCH] Build fix needed with taglib 2.0
+
+Fixes
+| ../gnome-commander-1.16.1/src/tags/gnome-cmd-tags-taglib.cc:153:29: error: no member named 'sampleWidth' in 'TagLib::FLAC::Properties'
+| 153 | if (flacProperties->sampleWidth())
+| | ~~~~~~~~~~~~~~ ^
+| ../gnome-commander-1.16.1/src/tags/gnome-cmd-tags-taglib.cc:154:67: error: no member named 'sampleWidth' in 'TagLib::FLAC::Properties'
+| 154 | cout << "Audio.FLAC.SampleWidth " << flacProperties->sampleWidth()<< endl;
+| | ~~~~~~~~~~~~~~ ^
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/tags/gnome-cmd-tags-taglib.cc | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/tags/gnome-cmd-tags-taglib.cc b/src/tags/gnome-cmd-tags-taglib.cc
+index 9e65836..573f5eb 100644
+--- a/src/tags/gnome-cmd-tags-taglib.cc
++++ b/src/tags/gnome-cmd-tags-taglib.cc
+@@ -150,8 +150,8 @@ bool getAudioProperties(GnomeCmdFileMetadata &metadata, const TagLib::AudioPrope
+ if (flacProperties)
+ {
+ metadata.add(TAG_AUDIO_CODEC,"FLAC");
+- if (flacProperties->sampleWidth())
+- cout << "Audio.FLAC.SampleWidth " << flacProperties->sampleWidth()<< endl;
++ if (flacProperties->bitsPerSample())
++ cout << "Audio.FLAC.BitsPerSample " << flacProperties->bitsPerSample()<< endl;
+
+ return true;
+ }
+--
+2.44.0
+
diff --git a/meta-gnome/recipes-gnome/gnome-commander/gnome-commander_1.16.1.bb b/meta-gnome/recipes-gnome/gnome-commander/gnome-commander_1.16.1.bb
index 474512daa8..bb36d59e56 100644
--- a/meta-gnome/recipes-gnome/gnome-commander/gnome-commander_1.16.1.bb
+++ b/meta-gnome/recipes-gnome/gnome-commander/gnome-commander_1.16.1.bb
@@ -16,6 +16,7 @@ ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
GIR_MESON_ENABLE_FLAG = 'enabled'
GIR_MESON_DISABLE_FLAG = 'disabled'
+SRC_URI += "file://0001-Build-fix-needed-with-taglib-2.0.patch"
SRC_URI[archive.sha256sum] = "3f1d00c4a650fe7902167648286b32c9ca4ef86e31a5d8ccca0139f12d10d0b3"
PACKAGECONFIG ??= "exiv2 taglib libgsf poppler"