aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-02-22 19:10:05 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-03-14 12:15:25 +0100
commitae08ee70a430789e08827bbb00958ae1bb7aabb3 (patch)
tree29097305affbc6518c95f7f0478b26b0d284e36f /meta-gnome
parent0acb0d7292edbb1e64b2d1ff04de439706ae4aa5 (diff)
downloadmeta-openembedded-contrib-ae08ee70a430789e08827bbb00958ae1bb7aabb3.tar.gz
gnumeric: fix gobject introspection support
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gnumeric/gnumeric/0001-configure.in-drop-introspection-macros-replace-them-.patch84
-rw-r--r--meta-gnome/recipes-gnome/gnumeric/gnumeric_1.12.0.bb5
2 files changed, 87 insertions, 2 deletions
diff --git a/meta-gnome/recipes-gnome/gnumeric/gnumeric/0001-configure.in-drop-introspection-macros-replace-them-.patch b/meta-gnome/recipes-gnome/gnumeric/gnumeric/0001-configure.in-drop-introspection-macros-replace-them-.patch
new file mode 100644
index 0000000000..914d2ccf99
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnumeric/gnumeric/0001-configure.in-drop-introspection-macros-replace-them-.patch
@@ -0,0 +1,84 @@
+From de5f0a535d6ea1932d2c7de53bd33510c8682ee7 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Mon, 22 Feb 2016 16:34:03 +0200
+Subject: [PATCH] configure.in: drop introspection macros, replace them with a
+ standard one
+
+Upstream-Status: Pending
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ configure.in | 57 +--------------------------------------------------------
+ 1 file changed, 1 insertion(+), 56 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index 8e1aa37..3086503 100644
+--- a/configure.in
++++ b/configure.in
+@@ -934,63 +934,8 @@ AC_SUBST(MONO_CFLAGS)
+ AC_SUBST(MONO_LIBS)
+ ])
+
+-# GObject Introspection
+-GIR_REQ=1.0.0
+-AC_ARG_ENABLE(introspection,
+- AS_HELP_STRING([--enable-introspection[=@<:@no/auto/yes@:>@]],
+- [Enable introspection for this build]),,
+- [enable_introspection=no])
+-
+-AC_MSG_CHECKING([for gobject-introspection])
+-
+-dnl presence/version checking
+-AS_CASE([$enable_introspection],
+-[no], [
+- found_introspection="no (disabled, use --enable-introspection to enable)"
+-],
+-[yes],[
+- PKG_CHECK_EXISTS([gobject-introspection-1.0],,
+- AC_MSG_ERROR([gobject-introspection-1.0 is not installed]))
+- PKG_CHECK_EXISTS([gobject-introspection-1.0 >= $GIR_REQ],
+- found_introspection=yes,
+- AC_MSG_ERROR([You need to have gobject-introspection >= $1 installed to build AC_PACKAGE_NAME]))
+-],
+-[auto],[
+- PKG_CHECK_EXISTS([gobject-introspection-1.0 >= $GIR_REQ], found_introspection=yes, found_introspection=no)
+-dnl Canonicalize enable_introspection
+-enable_introspection=$found_introspection
+-],
+-[
+- AC_MSG_ERROR([invalid argument passed to --enable-introspection, should be one of @<:@no/auto/yes@:>@])
+-])
++GOBJECT_INTROSPECTION_CHECK([1.46.0])
+
+-AC_MSG_RESULT([$found_introspection])
+-
+-INTROSPECTION_SCANNER=
+-INTROSPECTION_COMPILER=
+-INTROSPECTION_GENERATE=
+-INTROSPECTION_GIRDIR=
+-INTROSPECTION_TYPELIBDIR=
+-if test "x$found_introspection" = "xyes"; then
+- INTROSPECTION_SCANNER=`$PKG_CONFIG --variable=g_ir_scanner gobject-introspection-1.0`
+- INTROSPECTION_COMPILER=`$PKG_CONFIG --variable=g_ir_compiler gobject-introspection-1.0`
+- INTROSPECTION_GENERATE=`$PKG_CONFIG --variable=g_ir_generate gobject-introspection-1.0`
+- INTROSPECTION_GIRDIR=`$PKG_CONFIG --variable=girdir gobject-introspection-1.0`
+- INTROSPECTION_TYPELIBDIR="$($PKG_CONFIG --variable=typelibdir gobject-introspection-1.0)"
+- INTROSPECTION_CFLAGS=`$PKG_CONFIG --cflags gobject-introspection-1.0`
+- INTROSPECTION_LIBS=`$PKG_CONFIG --libs gobject-introspection-1.0`
+- INTROSPECTION_MAKEFILE=`$PKG_CONFIG --variable=datadir gobject-introspection-1.0`/gobject-introspection-1.0/Makefile.introspection
+-fi
+-AC_SUBST(INTROSPECTION_SCANNER)
+-AC_SUBST(INTROSPECTION_COMPILER)
+-AC_SUBST(INTROSPECTION_GENERATE)
+-AC_SUBST(INTROSPECTION_GIRDIR)
+-AC_SUBST(INTROSPECTION_TYPELIBDIR)
+-AC_SUBST(INTROSPECTION_CFLAGS)
+-AC_SUBST(INTROSPECTION_LIBS)
+-AC_SUBST(INTROSPECTION_MAKEFILE)
+-
+-AM_CONDITIONAL(HAVE_INTROSPECTION, test "x$found_introspection" = "xyes")
+ dnl we need to change the install directories for distcheck
+ AC_ARG_WITH([gir-dir],
+ AS_HELP_STRING(
+--
+2.7.0
+
diff --git a/meta-gnome/recipes-gnome/gnumeric/gnumeric_1.12.0.bb b/meta-gnome/recipes-gnome/gnumeric/gnumeric_1.12.0.bb
index 71f99cafbd..3d3118a927 100644
--- a/meta-gnome/recipes-gnome/gnumeric/gnumeric_1.12.0.bb
+++ b/meta-gnome/recipes-gnome/gnumeric/gnumeric_1.12.0.bb
@@ -7,9 +7,10 @@ SUMMARY = "Gnumeric spreadsheet for GNOME"
GNOME_COMPRESS_TYPE = "xz"
-inherit gnome
+inherit gnome pythonnative gobject-introspection
-SRC_URI += "file://do-not-use-srcdir.patch"
+SRC_URI += "file://do-not-use-srcdir.patch \
+ file://0001-configure.in-drop-introspection-macros-replace-them-.patch"
SRC_URI[archive.md5sum] = "3fd87cca95334b5d8ac922989670fe27"
SRC_URI[archive.sha256sum] = "037b53d909e5d1454b2afda8c4fb1e7838e260343e36d4e36245f4a5d0e04111"