aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-01-15 13:23:30 -0800
committerKhem Raj <raj.khem@gmail.com>2020-01-15 20:54:22 -0800
commit42ec7b02e81f47adec8b8fda3f72daa21cc415f7 (patch)
treef72c3720648659aeea307dd8bcfee6c4eea651fe /meta-gnome
parentdf61601333bf2fc8cb003f14e440a7de1582fd82 (diff)
downloadmeta-openembedded-contrib-42ec7b02e81f47adec8b8fda3f72daa21cc415f7.tar.gz
sysprof: avoid namesapace conflict with glibc headers
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-kernel/sysprof/files/0001-libsysprof-ui-Rename-environ-to-sys_environ.patch63
-rw-r--r--meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb5
2 files changed, 66 insertions, 2 deletions
diff --git a/meta-gnome/recipes-kernel/sysprof/files/0001-libsysprof-ui-Rename-environ-to-sys_environ.patch b/meta-gnome/recipes-kernel/sysprof/files/0001-libsysprof-ui-Rename-environ-to-sys_environ.patch
new file mode 100644
index 0000000000..1e2b3c92b4
--- /dev/null
+++ b/meta-gnome/recipes-kernel/sysprof/files/0001-libsysprof-ui-Rename-environ-to-sys_environ.patch
@@ -0,0 +1,63 @@
+From 4bd0d5d5dd6841fbac8385527617d18e7731244d Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 15 Jan 2020 13:17:58 -0800
+Subject: [PATCH] libsysprof-ui: Rename environ to sys_environ
+
+This helps avoid namesapace conflict with glibc headers
+
+Fixes
+/usr/include/unistd.h:545:15: note: previous declaration is here
+
+extern char **environ;
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/libsysprof-ui/sysprof-profiler-assistant.c | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/src/libsysprof-ui/sysprof-profiler-assistant.c b/src/libsysprof-ui/sysprof-profiler-assistant.c
+index 22e3e24..c55d551 100644
+--- a/src/libsysprof-ui/sysprof-profiler-assistant.c
++++ b/src/libsysprof-ui/sysprof-profiler-assistant.c
+@@ -235,7 +235,7 @@ sysprof_profiler_assistant_record_clicked_cb (SysprofProfilerAssistant *self,
+ {
+ g_auto(GStrv) argv = NULL;
+ g_auto(GStrv) env = NULL;
+- SysprofEnviron *environ;
++ SysprofEnviron *sys_environ;
+ const gchar *command;
+ gint argc;
+
+@@ -245,8 +245,8 @@ sysprof_profiler_assistant_record_clicked_cb (SysprofProfilerAssistant *self,
+ sysprof_profiler_set_spawn (profiler, TRUE);
+ sysprof_profiler_set_spawn_argv (profiler, (const gchar * const *)argv);
+
+- environ = sysprof_environ_editor_get_environ (self->environ_editor);
+- env = sysprof_environ_get_environ (environ);
++ sys_environ = sysprof_environ_editor_get_environ (self->environ_editor);
++ env = sysprof_environ_get_environ (sys_environ);
+ sysprof_profiler_set_spawn_env (profiler, (const gchar * const *)env);
+
+ sysprof_profiler_set_spawn_inherit_environ (profiler,
+@@ -405,7 +405,7 @@ sysprof_profiler_assistant_class_init (SysprofProfilerAssistantClass *klass)
+ static void
+ sysprof_profiler_assistant_init (SysprofProfilerAssistant *self)
+ {
+- g_autoptr(SysprofEnviron) environ = sysprof_environ_new ();
++ g_autoptr(SysprofEnviron) sys_environ = sysprof_environ_new ();
+
+ gtk_widget_init_template (GTK_WIDGET (self));
+
+@@ -445,7 +445,7 @@ sysprof_profiler_assistant_init (SysprofProfilerAssistant *self)
+ self,
+ G_CONNECT_SWAPPED);
+
+- sysprof_environ_editor_set_environ (self->environ_editor, environ);
++ sysprof_environ_editor_set_environ (self->environ_editor, sys_environ);
+ }
+
+ void
+--
+2.25.0
+
diff --git a/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb b/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb
index fd1b77eced..920bf10d65 100644
--- a/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb
+++ b/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb
@@ -12,8 +12,9 @@ DEPENDS = "glib-2.0 libxml2-native glib-2.0-native"
SRC_URI[archive.md5sum] = "cc32455277b31afb1965d627ae3e3629"
SRC_URI[archive.sha256sum] = "844bbb8d8b65071b3bca96f8e921319ceef81f2d2c51fcc9da63a4b355c893d0"
SRC_URI += "file://0001-sysprof-Define-NT_GNU_BUILD_ID-if-undefined.patch \
- file://0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch \
- "
+ file://0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch \
+ file://0001-libsysprof-ui-Rename-environ-to-sys_environ.patch \
+ "
PACKAGECONFIG ?= "sysprofd libsysprof ${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'gtk', '', d)}"
PACKAGECONFIG[gtk] = "-Denable_gtk=true,-Denable_gtk=false,gtk+3 libdazzle"