aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-08-25 00:14:19 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-28 11:06:06 +0200
commit59d3cd68b824b19b9675a9c5965cd86c871eeef5 (patch)
tree77891859bf809894d05445766a1a9e99228c40bb /meta-gnome
parentbcbd6884a57f7ee10629d7e3e40fbb09e17d8c13 (diff)
downloadmeta-openembedded-contrib-59d3cd68b824b19b9675a9c5965cd86c871eeef5.tar.gz
evolution-data-server: Fix build with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0001-imapx-Fix-signature-for-imapx_tokenise_struct.patch33
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb20
2 files changed, 43 insertions, 10 deletions
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-imapx-Fix-signature-for-imapx_tokenise_struct.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-imapx-Fix-signature-for-imapx_tokenise_struct.patch
new file mode 100644
index 0000000000..f82a76df33
--- /dev/null
+++ b/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-imapx-Fix-signature-for-imapx_tokenise_struct.patch
@@ -0,0 +1,33 @@
+From 0e10e976025b21d12df099e82951f759024ad649 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 24 Aug 2017 22:04:56 -0700
+Subject: [PATCH] imapx: Fix signature for imapx_tokenise_struct()
+
+clang complains about different signature for this patch
+
+Fixes
+camel/providers/imapx/camel-imapx-tokens.txt:56:1: error: conflicting types for 'imapx_tokenise_struct'
+| imapx_tokenise_struct (register const char *str, register size_t len)
+| ^
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ camel/providers/imapx/camel-imapx-tokens.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/camel/providers/imapx/camel-imapx-tokens.txt b/camel/providers/imapx/camel-imapx-tokens.txt
+index d48501865..994c368c0 100644
+--- a/camel/providers/imapx/camel-imapx-tokens.txt
++++ b/camel/providers/imapx/camel-imapx-tokens.txt
+@@ -1,7 +1,7 @@
+ /* This contains all of the keywords we care about. These
+ can be converted to an id very efficiently */
+ struct _imapx_keyword {const gchar *name; camel_imapx_id_t id; };
+-struct _imapx_keyword *imapx_tokenise_struct (register const char *str, register unsigned int len);
++struct _imapx_keyword *imapx_tokenise_struct (register const char *str, register size_t len);
+ %%
+ ALERT, IMAPX_ALERT
+ APPENDUID, IMAPX_APPENDUID
+--
+2.14.1
+
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb b/meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb
index ff3365bc90..aadc4b5e39 100644
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb
+++ b/meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb
@@ -15,16 +15,16 @@ SRCREV = "a9e4e74ec4473a4fd09e56b690bd4fa72f686687"
# 3.4 series needs libgdata-0.10*, 3.8 series needs also libsecret instead of gnome-keyring
PV = "3.2.3+git${SRCPV}"
-SRC_URI = " \
- git://git.gnome.org/evolution-data-server;branch=gnome-3-2 \
- file://0001-contact-Replace-the-Novell-sample-contact-with-somet.patch \
- file://0002-Fix-for-automake-1.12.x.patch \
- file://0003-Disable-Werror-for-automake.patch \
- file://0004-configure-Fix-libical-pkg-config-trying-to-use-host-.patch \
- file://0005-soup-adapt-to-new-libxml2-API-from-2.9.0.patch \
- file://0006-configure.ac-do-not-overwrite-localedir.patch \
- file://iconv-detect.h \
-"
+SRC_URI = "git://git.gnome.org/evolution-data-server;branch=gnome-3-2 \
+ file://0001-contact-Replace-the-Novell-sample-contact-with-somet.patch \
+ file://0002-Fix-for-automake-1.12.x.patch \
+ file://0003-Disable-Werror-for-automake.patch \
+ file://0004-configure-Fix-libical-pkg-config-trying-to-use-host-.patch \
+ file://0005-soup-adapt-to-new-libxml2-API-from-2.9.0.patch \
+ file://0006-configure.ac-do-not-overwrite-localedir.patch \
+ file://iconv-detect.h \
+ file://0001-imapx-Fix-signature-for-imapx_tokenise_struct.patch \
+ "
S = "${WORKDIR}/git"