aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-02 10:34:06 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-08 14:55:27 +0200
commit24fe575e796798fb0a41ae81bbd554e35b4cdb2e (patch)
tree7b14159472181acafb9376b36ed37bd87e3f9b8b /meta-gnome
parent80cf5e0ee961436fbcb2fa2c03cb709f79fa9e3c (diff)
downloadmeta-openembedded-contrib-24fe575e796798fb0a41ae81bbd554e35b4cdb2e.tar.gz
abiword, gnome-vfs: Use print as a function
In python 3, print is a function. Disable some pointless debug output whilst here. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb2
-rw-r--r--meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb2
2 files changed, 1 insertions, 3 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb b/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb
index 962a56cb9e..e0888c18fd 100644
--- a/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb
+++ b/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb
@@ -113,7 +113,7 @@ python populate_packages_prepend () {
packages = d.getVar('PACKAGES', 1).split()
for pkg in packages[1:]:
if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"):
- print "Modifying ", pkg
+ print("Modifying %s" % pkg)
metapkg_rdepends.append(pkg)
d.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends))
d.setVar('DESCRIPTION_' + metapkg, 'abiword-plugin meta package')
diff --git a/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb b/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb
index f9b02b1db0..1c784743fb 100644
--- a/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb
+++ b/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb
@@ -53,8 +53,6 @@ FILES_${PN}-doc += "${datadir}/gtk-doc"
PACKAGES_DYNAMIC += "^gnome-vfs-plugin-.*"
python populate_packages_prepend () {
- print d.getVar('FILES_gnome-vfs', 1)
-
plugindir = d.expand('${libdir}/gnome-vfs-2.0/modules/')
do_split_packages(d, plugindir, '^lib(.*)\.so$', 'gnome-vfs-plugin-%s', 'GNOME VFS plugin for %s')
}