aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-12-06 23:20:18 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2013-12-21 19:16:52 +0100
commit1cf6cecfeb93091f450ec0745c63100d4496648c (patch)
treefd7e7291b255e9b43250d385bfaaa3c1eeaab5f4 /meta-gnome
parent3766a8d15fd5940072b7ac94f21910fa5b44ce3a (diff)
downloadmeta-openembedded-contrib-1cf6cecfeb93091f450ec0745c63100d4496648c.tar.gz
libgnomeprint: Add missing dependency on freetype
Fixes compile errors like | gnome-rfont.c:31:30: fatal error: freetype/ftglyph.h: No such file or directory | #include <freetype/ftglyph.h> | ^ | compilation terminated. | make[3]: *** [gnome-rfont.lo] Error 1 Fix header inclusion mechanism for freetype headers Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gnome/libgnomeprint/freetype.patch38
-rw-r--r--meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.7.bb6
2 files changed, 42 insertions, 2 deletions
diff --git a/meta-gnome/recipes-gnome/gnome/libgnomeprint/freetype.patch b/meta-gnome/recipes-gnome/gnome/libgnomeprint/freetype.patch
new file mode 100644
index 0000000000..7a27ecd239
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome/libgnomeprint/freetype.patch
@@ -0,0 +1,38 @@
+Use proper method to include freetype headers
+
+FreeType wants to use these special macros to include its APIs
+so be it.
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream-Status: Pending
+
+Index: libgnomeprint-2.18.7/libgnomeprint/gnome-font-face.c
+===================================================================
+--- libgnomeprint-2.18.7.orig/libgnomeprint/gnome-font-face.c
++++ libgnomeprint-2.18.7/libgnomeprint/gnome-font-face.c
+@@ -36,7 +36,9 @@
+ #include <stdarg.h>
+ #include <locale.h>
+
+-#include <freetype/ftoutln.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
++
+
+ #include <libgnomeprint/gnome-print-private.h>
+ #include <libgnomeprint/gnome-font-private.h>
+Index: libgnomeprint-2.18.7/libgnomeprint/gnome-rfont.c
+===================================================================
+--- libgnomeprint-2.18.7.orig/libgnomeprint/gnome-rfont.c
++++ libgnomeprint-2.18.7/libgnomeprint/gnome-rfont.c
+@@ -28,8 +28,8 @@
+
+ #include <ft2build.h>
+ #include FT_FREETYPE_H
+-#include <freetype/ftglyph.h>
+-#include <freetype/ftbbox.h>
++#include FT_GLYPH_H
++#include FT_BBOX_H
+ #include <libart_lgpl/art_misc.h>
+ #include <libart_lgpl/art_affine.h>
+ #include <libart_lgpl/art_vpath.h>
diff --git a/meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.7.bb b/meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.7.bb
index 8e31f1dcd5..606c752e22 100644
--- a/meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.7.bb
+++ b/meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.7.bb
@@ -3,13 +3,15 @@ SECTION = "x11/gnome/libs"
PR = "r2"
-DEPENDS = "libxml2 libgnomecups glib-2.0 pango libart-lgpl fontconfig popt gnome-common"
+DEPENDS = "libxml2 libgnomecups glib-2.0 pango libart-lgpl fontconfig popt gnome-common freetype"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
inherit pkgconfig gnome
-SRC_URI += "file://fix.includes.patch"
+SRC_URI += "file://fix.includes.patch \
+ file://freetype.patch \
+ "
SRC_URI[archive.md5sum] = "d66b81ee8aa3b3a33f5efc9a47ce07e3"
SRC_URI[archive.sha256sum] = "8b34f81599423ef3da9c43775495da602f83cbbee069c9e760ffeae6aa4768e6"