aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorNoor <noor_ahsan@mentor.com>2013-06-17 11:11:42 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-07-12 12:06:02 +0200
commit54145480b0108b4f3e9f68f1b5572b9927076458 (patch)
treee54ebb78a9c02cd30b44605399fcd800f4de97e3 /meta-gnome
parente33cb25d595e8698c3936410a4ab508125c94d15 (diff)
downloadmeta-openembedded-contrib-54145480b0108b4f3e9f68f1b5572b9927076458.tar.gz
gvfs: Handle samba dependency based on GPLv3 license.
* Samba is GPLv3. In GPLv3 free environment one was not able to build gvfs. Add PACKAGECONFIG for samba and enable is when GPLv3 is not present in INCOMPATIBLE_LICENSE. Signed-off-by: Noor Ahsan <noor_ahsan@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gvfs/gvfs.inc4
-rw-r--r--meta-gnome/recipes-gnome/gvfs/gvfs_1.10.1.bb7
2 files changed, 7 insertions, 4 deletions
diff --git a/meta-gnome/recipes-gnome/gvfs/gvfs.inc b/meta-gnome/recipes-gnome/gvfs/gvfs.inc
index 4914285852..288b205da4 100644
--- a/meta-gnome/recipes-gnome/gvfs/gvfs.inc
+++ b/meta-gnome/recipes-gnome/gvfs/gvfs.inc
@@ -17,9 +17,7 @@ SRC_URI += " \
file://0004-Adapt-to-glib-thread-API-changes.patch \
"
-EXTRA_OECONF = "--with-samba-includes=${STAGING_INCDIR} \
- --with-samba-libs=${STAGING_LIBDIR} \
- --with-archive-includes=${STAGING_INCDIR} \
+EXTRA_OECONF = "--with-archive-includes=${STAGING_INCDIR} \
--with-archive-libs=${STAGING_LIBDIR} \
"
diff --git a/meta-gnome/recipes-gnome/gvfs/gvfs_1.10.1.bb b/meta-gnome/recipes-gnome/gvfs/gvfs_1.10.1.bb
index 9c21760b76..cab0d348e6 100644
--- a/meta-gnome/recipes-gnome/gvfs/gvfs_1.10.1.bb
+++ b/meta-gnome/recipes-gnome/gvfs/gvfs_1.10.1.bb
@@ -1,6 +1,6 @@
require gvfs.inc
-DEPENDS = "samba libsoup-2.4 gnome-keyring glib-2.0 fuse avahi fuse gconf libgphoto2"
+DEPENDS = "libsoup-2.4 gnome-keyring glib-2.0 fuse avahi fuse gconf libgphoto2"
# optional: obexftp libcdio libimobiledevice
PR = "${INC_PR}.0"
@@ -21,3 +21,8 @@ FILES_gvfsd-trash = "${libexecdir}/gvfsd-trash ${datadir}/gvfs/mounts/trash.moun
RDEPENDS_${PN} = "gvfs-gdu-volume-monitor"
RRECOMMENDS_gvfsd-ftp += "openssh-sftp openssh-ssh"
+
+PACKAGECONFIG ?= "${@base_contains('INCOMPATIBLE_LICENSE', 'GPLv3', '', 'samba', d)}"
+
+PACKAGECONFIG[samba] = "--enable-samba --with-samba-includes=${STAGING_INCDIR} \
+ --with-samba-libs=${STAGING_LIBDIR}, --disable-samba, samba"