aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-08-25 19:51:33 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-09-17 19:13:53 +0200
commitde36f51387f7135f12c08038424c988f915cf55d (patch)
tree8a9f8aff0bc0d3f07b37961de3447d6a6d4b99d6 /meta-gnome
parent1c99de08903a399324799e29d2bb4775d1c22704 (diff)
downloadmeta-openembedded-contrib-de36f51387f7135f12c08038424c988f915cf55d.tar.gz
abiword: Add PACKAGECONFIG for collab-backends and spell
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb15
1 files changed, 10 insertions, 5 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb b/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb
index 1aa88cbe3c..11565e3c6f 100644
--- a/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb
+++ b/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb
@@ -3,8 +3,8 @@ HOMEPAGE = "http://www.abiword.org"
SECTION = "x11/office"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=ecd3ac329fca77e2d0e412bec38e1c20"
-DEPENDS = "perl-native wv libgsf libglade libfribidi jpeg libpng libxml2 \
- librsvg loudmouth libwmf-native gtkmathview asio"
+DEPENDS = "perl-native wv libglade libfribidi jpeg libpng \
+ librsvg libwmf-native gtkmathview asio"
RDEPENDS_${PN} = "glibc-gconv-ibm850 glibc-gconv-cp1252 \
glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
RCONFLICTS_${PN} = "${PN}-embedded"
@@ -31,12 +31,17 @@ inherit autotools pkgconfig
PARALLEL_MAKE = ""
+PACKAGECONFIG ??= "collab-backend-xmpp collab-backend-tcp collab-backend-service"
+PACKAGECONFIG[spell] = "--enable-spell,--disable-spell,enchant"
+PACKAGECONFIG[collab-backend-xmpp] = "--enable-collab-backend-xmpp,--disable-collab-backend-xmpp,libgsf libxml2 loudmouth gtk+"
+PACKAGECONFIG[collab-backend-tcp] = "--enable-collab-backend-tcp,--disable-collab-backend-tcp,libgsf libxml2"
+PACKAGECONFIG[collab-backend-service] = "--enable-collab-backend-service,--disable-collab-backend-service,libgsf libxml2 libsoup-2.4 gnutls"
+PACKAGECONFIG[collab-backend-telepathy] = "--enable-collab-backend-telepathy,--disable-collab-backend-telepathy,libgsf libxml2 telepathy-glib telepathy-mission-control"
+PACKAGECONFIG[collab-backend-sugar] = "--enable-collab-backend-sugar,--disable-collab-backend-sugar,libgsf libxml2 dbus-glib"
+
EXTRA_OECONF = " --disable-static \
--enable-plugins \
--without-gnomevfs \
- --enable-collab-backend-xmpp \
- --enable-collab-backend-tcp \
- --enable-collab-backend-service \
--with-libwmf-config=${STAGING_DIR} \
"