aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2022-04-11 00:35:31 +0200
committerKhem Raj <raj.khem@gmail.com>2022-04-11 07:46:51 -0700
commitb74602b407379f48bfd19e5d42e3f6618bd021e1 (patch)
treeb688e4145d22d0bef0d2873136aaa7a181c16623 /meta-gnome
parent10726b25575d5d7b8200ba9eaa221dfddf240438 (diff)
downloadmeta-openembedded-contrib-b74602b407379f48bfd19e5d42e3f6618bd021e1.tar.gz
gnome-shell: upgrade 41.2 -> 42.0
* Backported patch can go * Adding gtk-icon-cache unveiled a misconception: DEPENDS overwrote those added by inherit Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gnome-shell/gnome-shell/0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch20
-rw-r--r--meta-gnome/recipes-gnome/gnome-shell/gnome-shell/0001-build-Drop-incorrect-positional-arg.patch81
-rw-r--r--meta-gnome/recipes-gnome/gnome-shell/gnome-shell_42.0.bb (renamed from meta-gnome/recipes-gnome/gnome-shell/gnome-shell_41.2.bb)12
3 files changed, 16 insertions, 97 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-shell/gnome-shell/0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell/0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch
index 15e3c8c647..4a36625184 100644
--- a/meta-gnome/recipes-gnome/gnome-shell/gnome-shell/0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch
+++ b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell/0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch
@@ -19,25 +19,25 @@ Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
6 files changed, 25 insertions(+), 4 deletions(-)
diff --git a/js/dbusServices/meson.build b/js/dbusServices/meson.build
-index 68e8bd12d..16efaebe5 100644
+index eb941ed..16efaeb 100644
--- a/js/dbusServices/meson.build
+++ b/js/dbusServices/meson.build
@@ -27,7 +27,7 @@ foreach service, dir : dbus_services
serviceconf = configuration_data()
serviceconf.set('service', service)
-- serviceconf.set('gjs', gjs.path())
+- serviceconf.set('gjs', gjs.full_path())
+ serviceconf.set('gjs', gjs)
serviceconf.set('pkgdatadir', pkgdatadir)
configure_file(
diff --git a/meson.build b/meson.build
-index d4583ecf2..3448c6312 100644
+index 8d7478f..7c9cc6a 100644
--- a/meson.build
+++ b/meson.build
@@ -138,7 +138,11 @@ endif
- mutter_typelibdir = mutter_dep.get_pkgconfig_variable('typelibdir')
+ mutter_typelibdir = mutter_dep.get_variable('typelibdir')
python = find_program('python3')
-gjs = find_program('gjs')
+if get_option('gjs_path') == ''
@@ -49,7 +49,7 @@ index d4583ecf2..3448c6312 100644
cc = meson.get_compiler('c')
diff --git a/meson_options.txt b/meson_options.txt
-index f0f2ecf6c..a45f2e453 100644
+index f0f2ecf..a45f2e4 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -45,3 +45,9 @@ option('soup2',
@@ -63,20 +63,20 @@ index f0f2ecf6c..a45f2e453 100644
+ description: 'Instead of searching gjs executable, configure path'
+)
diff --git a/subprojects/extensions-app/js/meson.build b/subprojects/extensions-app/js/meson.build
-index f311db6e0..8f7bba4e4 100644
+index ce2a776..8f7bba4 100644
--- a/subprojects/extensions-app/js/meson.build
+++ b/subprojects/extensions-app/js/meson.build
@@ -9,7 +9,7 @@ endif
launcherconf.set('prefix', prefix)
launcherconf.set('libdir', libdir)
launcherconf.set('pkgdatadir', pkgdatadir)
--launcherconf.set('gjs', gjs.path())
+-launcherconf.set('gjs', gjs.full_path())
+launcherconf.set('gjs', gjs)
configure_file(
input: prgname + '.in',
diff --git a/subprojects/extensions-app/meson.build b/subprojects/extensions-app/meson.build
-index f9ccfc24d..bdf118975 100644
+index c260d7a..c5b7554 100644
--- a/subprojects/extensions-app/meson.build
+++ b/subprojects/extensions-app/meson.build
@@ -44,7 +44,12 @@ localedir = join_paths(datadir, 'locale')
@@ -94,7 +94,7 @@ index f9ccfc24d..bdf118975 100644
desktop_file_validate = find_program('desktop-file-validate', required: false)
diff --git a/subprojects/extensions-app/meson_options.txt b/subprojects/extensions-app/meson_options.txt
-index ca2eb4115..2787785bf 100644
+index ca2eb41..2787785 100644
--- a/subprojects/extensions-app/meson_options.txt
+++ b/subprojects/extensions-app/meson_options.txt
@@ -10,3 +10,9 @@ option('profile',
@@ -108,5 +108,5 @@ index ca2eb4115..2787785bf 100644
+ description: 'Instead of searching gjs executable, configure path'
+)
--
-2.31.1
+2.34.1
diff --git a/meta-gnome/recipes-gnome/gnome-shell/gnome-shell/0001-build-Drop-incorrect-positional-arg.patch b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell/0001-build-Drop-incorrect-positional-arg.patch
deleted file mode 100644
index edc32dee6c..0000000000
--- a/meta-gnome/recipes-gnome/gnome-shell/gnome-shell/0001-build-Drop-incorrect-positional-arg.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-From 6f797c21703ce9e996da17c49879e2a16dfbc256 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
-Date: Thu, 23 Dec 2021 17:18:16 +0100
-Subject: [PATCH] build: Drop incorrect positional arg
-
-Unlike other targets that take a name, i18n.merge_file() does not.
-
-Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell/-/merge_requests/2078>
-Upstream-Status: Backport
-Signed-off-by: Alexander Kanavin <alex@linutronix.de>
----
- data/meson.build | 2 +-
- src/calendar-server/meson.build | 2 +-
- subprojects/extensions-app/data/meson.build | 2 +-
- subprojects/extensions-app/data/metainfo/meson.build | 2 +-
- subprojects/extensions-tool/src/templates/meson.build | 2 +-
- 5 files changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/data/meson.build b/data/meson.build
-index f924fdf..76ae45c 100644
---- a/data/meson.build
-+++ b/data/meson.build
-@@ -16,7 +16,7 @@ desktopconf.set('bindir', bindir)
- desktopconf.set('systemd_hidden', have_systemd ? 'true' : 'false')
-
- foreach desktop_file : desktop_files
-- i18n.merge_file('desktop',
-+ i18n.merge_file(
- input: configure_file(
- input: desktop_file + '.in.in',
- output: desktop_file + '.in',
-diff --git a/src/calendar-server/meson.build b/src/calendar-server/meson.build
-index 7363282..8b4ef41 100644
---- a/src/calendar-server/meson.build
-+++ b/src/calendar-server/meson.build
-@@ -27,7 +27,7 @@ configure_file(
- install_dir: servicedir
- )
-
--i18n.merge_file('evolution-calendar.desktop',
-+i18n.merge_file(
- input: 'evolution-calendar.desktop.in',
- output: 'evolution-calendar.desktop',
- po_dir: po_dir,
-diff --git a/subprojects/extensions-app/data/meson.build b/subprojects/extensions-app/data/meson.build
-index d7e7d40..4b601e8 100644
---- a/subprojects/extensions-app/data/meson.build
-+++ b/subprojects/extensions-app/data/meson.build
-@@ -14,7 +14,7 @@ desktopconf.set('bindir', bindir)
- desktopconf.set('app_id', app_id)
- desktopconf.set('prgname', prgname)
-
--i18n.merge_file('desktop',
-+i18n.merge_file(
- input: configure_file(
- input: base_id + '.desktop.in.in',
- output: desktop_file + '.in',
-diff --git a/subprojects/extensions-app/data/metainfo/meson.build b/subprojects/extensions-app/data/metainfo/meson.build
-index c4962c0..a19bfa8 100644
---- a/subprojects/extensions-app/data/metainfo/meson.build
-+++ b/subprojects/extensions-app/data/metainfo/meson.build
-@@ -1,5 +1,5 @@
- metainfo = app_id + '.metainfo.xml'
--i18n.merge_file(metainfo,
-+i18n.merge_file(
- input: base_id + '.metainfo.xml.in',
- output: metainfo,
- po_dir: po_dir,
-diff --git a/subprojects/extensions-tool/src/templates/meson.build b/subprojects/extensions-tool/src/templates/meson.build
-index 670e2bf..d693bfa 100644
---- a/subprojects/extensions-tool/src/templates/meson.build
-+++ b/subprojects/extensions-tool/src/templates/meson.build
-@@ -4,7 +4,7 @@ template_metas = [
- ]
- template_deps = []
- foreach template : template_metas
-- template_deps += i18n.merge_file(template,
-+ template_deps += i18n.merge_file(
- input: template + '.in',
- output: template,
- po_dir: po_dir,
diff --git a/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_41.2.bb b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_42.0.bb
index 8d0dba4840..f54d966c73 100644
--- a/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_41.2.bb
+++ b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_42.0.bb
@@ -4,10 +4,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
GNOMEBASEBUILDCLASS = "meson"
-inherit gnomebase gsettings gettext gobject-introspection features_check bash-completion
-
-REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam"
-
DEPENDS = " \
libxml2-native \
sassc-native \
@@ -24,15 +20,19 @@ DEPENDS = " \
gsettings-desktop-schemas \
"
+inherit gnomebase gsettings gettext gobject-introspection gtk-icon-cache features_check bash-completion
+
+REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam"
+
+GTKIC_VERSION = "4"
GTKDOC_MESON_OPTION = "gtk_doc"
GIR_MESON_OPTION = ""
# gobject-introspection is mandatory and cannot be configured
REQUIRED_DISTRO_FEATURES += "gobject-introspection-data"
-SRC_URI[archive.sha256sum] = "384651eb051393dbabe006d1ad057bf29d5cd73ebb87bc779ff5e1c31e80a827"
+SRC_URI[archive.sha256sum] = "33d404fb3c93b9de42984f0110a2969d6a4a7247c27fe7f5e24c67ecfec75094"
SRC_URI += "file://0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch"
-SRC_URI += " file://0001-build-Drop-incorrect-positional-arg.patch"
PACKAGECONFIG ??= "bluetooth nm ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
PACKAGECONFIG[bluetooth] = ",,gnome-bluetooth"