aboutsummaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-08-11 14:51:13 -0700
committerKhem Raj <raj.khem@gmail.com>2018-08-15 08:20:06 -0700
commit85b0d91d397fd46922c9266db13e725f36968837 (patch)
tree69070c7e06c65ba034d81bc79daff89524e7eb8e /meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
parentb19f8c7d6e98b911620ea6fdb606339f49aca18a (diff)
downloadmeta-openembedded-contrib-85b0d91d397fd46922c9266db13e725f36968837.tar.gz
kexecboot: Fix build with glibc 2.28+
Update to latest srcrev at the same time. Fix out of tree builds Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb')
-rw-r--r--meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
index 9f5dad7c64..8799a3e4cc 100644
--- a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
+++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
@@ -38,15 +38,17 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
PV = "0.6+git${SRCPV}"
S = "${WORKDIR}/git"
-SRC_URI = "git://github.com/kexecboot/kexecboot.git"
-SRCREV = "4c4f127e79ac5b8d6b6e2fbb938ccbf12b04c531"
+SRC_URI = "git://github.com/kexecboot/kexecboot.git \
+ file://0001-Add-top_srcdir-to-compiler-include-paths.patch \
+ file://0002-include-sys-sysmacros.h.patch \
+ "
+SRCREV = "d5ffd81bf6a1a2087cdc6c606cae98099229131c"
inherit autotools
EXTRA_OECONF = "--enable-textui --enable-delay=2 --enable-evdev-rate=1000,250"
do_install () {
- install -d ${D}${bindir}
- install -m 0755 kexecboot ${D}${bindir}
+ install -D -m 0755 ${B}/src/kexecboot ${D}${bindir}/kexecboot
install -d ${D}/proc
install -d ${D}/mnt
install -d ${D}/dev