aboutsummaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2013-10-11 00:05:12 +0200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2013-10-11 00:30:57 +0100
commit9b3e6816855ac126d7d5edc92d83f6efe9889b47 (patch)
tree8a8b5f3448c8a92436b8a18542b40dd504d5d0c6 /meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
parente25a3b60e4a9d6c99c03417f28a8c8d5e9e07016 (diff)
downloadmeta-openembedded-contrib-9b3e6816855ac126d7d5edc92d83f6efe9889b47.tar.gz
kexecboot: update to v0.6 and restylize
Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Diffstat (limited to 'meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb')
-rw-r--r--meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb67
1 files changed, 0 insertions, 67 deletions
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
deleted file mode 100644
index 7347ea5982..0000000000
--- a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
+++ /dev/null
@@ -1,67 +0,0 @@
-###########################
-# Configure options:
-#
-# --enable-static-linking compile kexecboot as static executable [default=no]
-# --enable-fbui support framebuffer menu [default=yes]
-# --enable-fbui-width limit FB UI width to specified value [default=no]
-# --enable-fbui-height limit FB UI height to specified value [default=no]
-# --enable-textui support console text user interface [default=no]
-# --enable-cfgfiles support config files [default=yes]
-# --enable-icons support custom icons (depends on fbui) [default=yes]
-# --enable-zaurus compile Sharp Zaurus specific code [default=no]
-# --enable-zimage compile with zImage support [default=yes]
-# --enable-uimage compile with uImage support [default=no]
-# --enable-machine-kernel look for machine-specific zImage kernel [default=no]
-# --enable-devices-recreating
-# enable devices re-creating [default=yes]
-# --enable-debug enable debug output [default=no]
-# --enable-host-debug allow for non-destructive executing of kexecboot on
-# host system [default=no]
-# --enable-numkeys enable menu item selection by keys [0-9] [default=yes]
-# --enable-bg-buffer enable buffer for pre-drawed FB GUI background
-#
-# --enable-timeout allow to boot 1st kernel after timeout in seconds
-# [default=no]
-# --enable-delay specify delay before device scanning, allowing
-# initialization of old CF/SD cards [default=1]
-# --enable-bpp enable support of specified bpp modes
-# (all,32,24,18,16,4,2,1) [default=all]
-# --enable-evdev-rate change evdev (keyboard/mouse) repeat rate
-# in milliseconds e.g. "1000,250" [default=no]
-# --with-kexec-binary look for kexec binary at path
-# [default="/usr/sbin/kexec"]
-##########################
-SUMMARY = "kexecboot linux-as-bootloader"
-DESCRIPTION = "kexecboot is a graphical linux-as-bootloader implementation based on kexec."
-HOMEPAGE = "http://kexecboot.org"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-SRCREV = "0bcc14671aa2d84ec20f260582aca36bb901ccf1"
-PV = "0.5.9.1"
-
-SRC_URI = "git://github.com/kexecboot/kexecboot.git"
-
-S = "${WORKDIR}/git"
-
-inherit autotools
-
-EXTRA_OECONF = "--enable-delay=2 --enable-evdev-rate=1000,250"
-
-do_install () {
- install -d ${D}${bindir}
- install -m 0755 kexecboot ${D}${bindir}/
- install -d ${D}/proc
- install -d ${D}/mnt
- install -d ${D}/dev
- install -d ${D}/sys
-}
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt /dev /sys"
-
-pkg_postinst_${PN} () {
- ln -sf ${bindir}/kexecboot $D/init
-}
-
-BBCLASSEXTEND = "klibc"