aboutsummaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-devtools/dracut/dracut_git.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-11-20 02:05:10 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-12-18 12:30:22 +0100
commit892c0ad6051019ec89a28147e06cdc61e42eb130 (patch)
tree89fb4d41639527042986ad5141f0ced2c776a83f /meta-initramfs/recipes-devtools/dracut/dracut_git.bb
parentd1a18f5db13c251daa23201fe270c843082f0e63 (diff)
downloadmeta-openembedded-contrib-892c0ad6051019ec89a28147e06cdc61e42eb130.tar.gz
dracut: fix host-user-contaminated
Fixed: dracut-043+giteab03540cd695d940062af5b55c02e8829aaa526: dracut: /dracut/usr/lib/dracut/modules.d/99img-lib/img-lib.sh is owned by uid 15220, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated] lib32-dracut-043+giteab03540cd695d940062af5b55c02e8829aaa526: lib32-dracut: /lib32-dracut/usr/lib/dracut/modules.d/99img-lib/img-lib.sh is owned by uid 15220, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated] Its Makefile uses cp -arx to install modules.d, so fix the owner to root:root Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-initramfs/recipes-devtools/dracut/dracut_git.bb')
-rw-r--r--meta-initramfs/recipes-devtools/dracut/dracut_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-devtools/dracut/dracut_git.bb b/meta-initramfs/recipes-devtools/dracut/dracut_git.bb
index 91a83214db..e026da7101 100644
--- a/meta-initramfs/recipes-devtools/dracut/dracut_git.bb
+++ b/meta-initramfs/recipes-devtools/dracut/dracut_git.bb
@@ -36,6 +36,9 @@ do_configure() {
do_install() {
oe_runmake install DESTDIR=${D}
+ # Its Makefile uses cp -arx to install modules.d, so fix the owner
+ # to root:root
+ chown -R root:root ${D}/${prefix}/lib/dracut/modules.d
}
PACKAGES =+ "${PN}-bash-completion"