aboutsummaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-devtools
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2014-05-03 18:09:49 +0200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2014-05-04 11:41:12 +0100
commit55b09e522ca88c0c0b2dd7a36e4861a1cf6ca9c6 (patch)
treeec217387dbc24834361522bc088009c28be6e015 /meta-initramfs/recipes-devtools
parent7e2c29fca8ab46ef1eee841eeccc36cdf76222a2 (diff)
downloadmeta-openembedded-contrib-55b09e522ca88c0c0b2dd7a36e4861a1cf6ca9c6.tar.gz
klcc_cross: move in target sysroot as crossscript
Klcc-cross is properly a crosscript so avoid to inherit cross.bbclass and stage it in target sysroot under usr/bin/crossscripts. Minor adjustment is necessary for INSTALLDIR. Finally some magic mangling is applied fixing the paths of sstate so that it is invalidated in case of subsequent builds targeting machines with the same arch and in case of builds sharing the sstate cache. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Diffstat (limited to 'meta-initramfs/recipes-devtools')
-rw-r--r--meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.3.bb40
1 files changed, 23 insertions, 17 deletions
diff --git a/meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.3.bb b/meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.3.bb
index 7ff9c2e1af..2f4afce063 100644
--- a/meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.3.bb
+++ b/meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.3.bb
@@ -7,28 +7,34 @@ FILESPATH =. "${FILE_DIRNAME}/klibc-${PV}:"
SRC_URI += "file://use-env-for-perl.patch"
-inherit cross
-
# disable task already run in klibc recipe
do_configure[noexec] = "1"
+
do_compile() {
- oe_runmake 'INSTALLDIR=${STAGING_DIR_TARGET}${target_libdir}/klibc' klcc
+ oe_runmake 'INSTALLDIR=${STAGING_DIR_TARGET}${libdir}/klibc' klcc
}
-# The linux-libc-headers and klibc custom headers are not machine-specific
-# but are installed into machine sysroot.
-# Klcc wrapper is hardcoding some of these paths thus, to keep the recipe
-# arch-specific, we force the rebuild of klcc-cross for each machine.
-do_compile[vardeps] += "MACHINE"
+
do_install() {
- install -d ${D}${bindir}
- install -m 0755 klcc/klcc ${D}${bindir}/${TARGET_PREFIX}klcc
+ install -d ${D}${bindir_crossscripts}/
+ install -m 0755 klcc/klcc ${D}${bindir_crossscripts}/${TARGET_PREFIX}klcc
+ # Insert an unencoded path as a comment to trigger the sstate renaming functions
+ sed -i '2i #${STAGING_DIR_TARGET}' ${D}${bindir_crossscripts}/${TARGET_PREFIX}klcc
+}
+
+SYSROOT_PREPROCESS_FUNCS += "klcc_sysroot_preprocess"
+
+klcc_sysroot_preprocess () {
+ sysroot_stage_dir ${D}${bindir_crossscripts} ${SYSROOT_DESTDIR}${bindir_crossscripts}
}
+deltask do_package
+deltask do_packagedata
+deltask do_package_write_ipk
+deltask do_package_write_rpm
+deltask do_package_write_deb
+deltask do_package_write_tar
-# disable unneeded tasks
-do_package[noexec] = "1"
-do_packagedata[noexec] = "1"
-do_package_write_ipk[noexec] = "1"
-do_package_write_rpm[noexec] = "1"
-do_package_write_deb[noexec] = "1"
-do_package_write_tar[noexec] = "1"
+SSTATE_SCAN_FILES = "*"
+EXTRA_STAGING_FIXMES = "MANGLEDSTAGINGDIRTARGET MANGLEDSTAGINGDIR"
+MANGLEDSTAGINGDIR = "${@d.getVar("STAGING_DIR", True).replace("/", "\\\\/").replace("-", "\\\\-")}"
+MANGLEDSTAGINGDIRTARGET = "${@d.getVar("STAGING_DIR_TARGET", True).replace("/", "\\\\/").replace("-", "\\\\-")}"