aboutsummaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2013-05-13 01:22:23 +0200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2013-05-13 09:50:24 +0100
commit97957e5cee9a797d3e05c1a8848338a033f40770 (patch)
tree59351568b51e711b80ca3fff348e61d9079eaf01 /meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb
parent06318f320803814ac7f2827473a8e46a8eb0d8cb (diff)
downloadmeta-openembedded-contrib-97957e5cee9a797d3e05c1a8848338a033f40770.tar.gz
kexec-tools-klibc_2.0.2: refactor and extend patches for building
* some old patches apparently unneeded have been removed * patches are now better split * fix build for x86 and x86-64 * tested with qemuarm, qemuppc, qemumips, qemux86, qemux86-64 Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Diffstat (limited to 'meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb')
-rw-r--r--meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb28
1 files changed, 19 insertions, 9 deletions
diff --git a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb
index 90b876cdde..eedcaa557c 100644
--- a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb
+++ b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb
@@ -7,20 +7,30 @@ inherit klibc
FILESPATH =. "${FILE_DIRNAME}/kexec-tools-${PV}:"
-SRC_URI += "file://elf.patch \
- file://errno.patch \
- file://string.patch \
- file://syscall.patch \
- file://other.patch \
-"
+SRC_URI += " \
+ file://kexec-elf-rel.patch \
+ file://kexec-syscall.patch \
+ file://cflags_static.patch \
+ file://ifdown_errno.patch \
+ file://purgatory_flags.patch \
+ file://purgatory_string.patch \
+ file://sha256.patch \
+ file://sysconf_nrprocessors.patch \
+ "
+
+SRC_URI_append_arm = " file://arm_crashdump.patch"
+SRC_URI_append_powerpc = " file://ppc__lshrdi3.patch"
+SRC_URI_append_x86 = " file://x86_sys_io.patch file://x86_basename.patch file://x86_vfscanf.patch file://x86_kexec_test.patch"
+SRC_URI_append_x86-64 = " file://x86_sys_io.patch file://x86_basename.patch file://x86_vfscanf.patch file://x86_kexec_test.patch"
S = "${WORKDIR}/kexec-tools-${PV}"
-EXTRA_OECONF += "--without-zlib"
-
-PACKAGES =+ "kexec-klibc kdump-klibc"
+EXTRA_OECONF += "--without-zlib --without-lzma --without-xen"
CFLAGS += "-I${STAGING_DIR_HOST}${base_libdir}/klibc/include -I${STAGING_DIR_HOST}${base_libdir}/klibc/include/bits32"
+CFLAGS_x86-64 += "-I${STAGING_DIR_HOST}${base_libdir}/klibc/include -I${STAGING_DIR_HOST}${base_libdir}/klibc/include/bits64"
+
+PACKAGES =+ "kexec-klibc kdump-klibc"
FILES_kexec-klibc = "${sbindir}/kexec"
FILES_kdump-klibc = "${sbindir}/kdump"