aboutsummaryrefslogtreecommitdiffstats
path: root/meta-initramfs
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2013-10-10 23:26:25 +0200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2013-10-11 00:27:39 +0100
commite25a3b60e4a9d6c99c03417f28a8c8d5e9e07016 (patch)
tree38e4395a0892cc2154c0afbdaaa13c80b29e1a9f /meta-initramfs
parent0eaa9888882dcf393f7244578854baf8c2d8a4cf (diff)
downloadmeta-openembedded-contrib-e25a3b60e4a9d6c99c03417f28a8c8d5e9e07016.tar.gz
kexecboot_cfg: process with oe-stylize.py
Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Diffstat (limited to 'meta-initramfs')
-rw-r--r--meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb19
1 files changed, 8 insertions, 11 deletions
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb b/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb
index af3320f8a7..ff91b201ee 100644
--- a/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb
+++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb
@@ -3,23 +3,13 @@ DESCRIPTION = "Default icon and boot.cfg for kexecboot linux-as-bootloader."
SECTION = "base"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-
PR = "r14"
-INHIBIT_DEFAULT_DEPS = "1"
-
SRC_URI = "file://icon.xpm"
-CMDLINE ?= ""
-CMDLINE_DEBUG ?= "quiet"
-
-# Note: for qvga the label is currently limited to about 24 chars
-KEXECBOOT_LABEL ?= "${@d.getVar('DISTRO', True) or d.getVar('DISTRO_VERSION', True)}-${MACHINE}"
-
do_configure_prepend () {
install -m 0644 ${WORKDIR}/icon.xpm ${S}
}
-
do_install_prepend () {
echo '# /boot/boot.cfg - KEXECBOOT configuration file.
#
@@ -53,7 +43,6 @@ APPEND=${CMDLINE} ${CMDLINE_DEBUG}
# APPEND=${CMDLINE}
#' > ${S}/boot.cfg
}
-
do_install () {
install -d ${D}/boot
install -m 0644 boot.cfg ${D}/boot/boot.cfg
@@ -63,3 +52,11 @@ do_install () {
PACKAGE_ARCH = "${MACHINE_ARCH}"
FILES_${PN} += "/boot/*"
+
+CMDLINE ?= ""
+CMDLINE_DEBUG ?= "quiet"
+
+INHIBIT_DEFAULT_DEPS = "1"
+
+# Note: for qvga the label is currently limited to about 24 chars
+KEXECBOOT_LABEL ?= "${@d.getVar('DISTRO', True) or d.getVar('DISTRO_VERSION', True)}-${MACHINE}"