aboutsummaryrefslogtreecommitdiffstats
path: root/meta-initramfs
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2021-06-13 00:53:58 +0200
committerKhem Raj <raj.khem@gmail.com>2021-06-12 23:02:49 -0700
commitcdce92b4e9e82327fe2b3118384c424d7f08cc0c (patch)
tree22a1e8d6c3291c02a266031549d3c91b144b8d0d /meta-initramfs
parent189cdf4337aa2098eb447e82264143392a947334 (diff)
downloadmeta-openembedded-contrib-cdce92b4e9e82327fe2b3118384c424d7f08cc0c.tar.gz
initramfs-kexecboot-image: support cases where machines override IMAGE_FSTYPES
test case: zaurus.inc IMAGE_FSTYPES ?= "tar.gz jffs2 jffs2.sum ubi ubifs" IMAGE_FSTYPES_collie ?= "tar.gz jffs2 jffs2.sum" INITRAMFS_FSTYPES ?= "cpio.gz cpio.xz" The last assignment IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}" did in fact reset the value to IMAGE_FSTYPES_collie, thus not producing cpio.gz / cpio.xz. Signed-off-by: Andrea Adami <andrea.adami@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-initramfs')
-rw-r--r--meta-initramfs/recipes-core/images/initramfs-kexecboot-image.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-initramfs/recipes-core/images/initramfs-kexecboot-image.bb b/meta-initramfs/recipes-core/images/initramfs-kexecboot-image.bb
index 9a686f366f..dd082ba529 100644
--- a/meta-initramfs/recipes-core/images/initramfs-kexecboot-image.bb
+++ b/meta-initramfs/recipes-core/images/initramfs-kexecboot-image.bb
@@ -1,9 +1,13 @@
SUMMARY = "Initramfs image for kexecboot kernel"
DESCRIPTION = "This image provides kexecboot (linux as bootloader) and helpers."
-inherit image
+# Some BSPs use IMAGE_FSTYPES_<machine override> which would override
+# an assignment to IMAGE_FSTYPES so we need anon python
+python () {
+ d.setVar("IMAGE_FSTYPES", d.getVar("INITRAMFS_FSTYPES"))
+}
-IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
+inherit image
# avoid circular dependencies
EXTRA_IMAGEDEPENDS = ""