aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-mkv/libebml/libebml/override-uname.patch
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2016-06-17 13:34:49 -0700
committerArmin Kuster <akuster808@gmail.com>2016-08-16 10:29:41 -0700
commit9ecd1e0e1395d1af605260c3617e700563205eef (patch)
treed4a7be9225d140042c13865ab400874bba372aad /meta-multimedia/recipes-mkv/libebml/libebml/override-uname.patch
parent2be8e0fe2f61685758e0f0b2508e950d4cb7c805 (diff)
downloadmeta-openembedded-contrib-9ecd1e0e1395d1af605260c3617e700563205eef.tar.gz
libebml: don't rely on make -e, obey LDFLAGS
We need to obey LDFLAGS to get the correct hash style for external toolchains, and passing vars explicitly is better than relying on implicitly overriding everything blindly from the environment. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 64d874f768207a8a1e27a5c6edd3abe90607af03) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-mkv/libebml/libebml/override-uname.patch')
-rw-r--r--meta-multimedia/recipes-mkv/libebml/libebml/override-uname.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-mkv/libebml/libebml/override-uname.patch b/meta-multimedia/recipes-mkv/libebml/libebml/override-uname.patch
new file mode 100644
index 0000000000..57eb3450d6
--- /dev/null
+++ b/meta-multimedia/recipes-mkv/libebml/libebml/override-uname.patch
@@ -0,0 +1,42 @@
+Allow override of the 'uname -s' for cross-compilation
+
+Signed-off-by: Christopher Larson <chris_larson@mentor.com>
+Upstream-Status: Pending
+
+diff --git a/make/linux/Makefile b/make/linux/Makefile
+index a2ac13e..4188bee 100644
+--- a/make/linux/Makefile
++++ b/make/linux/Makefile
+@@ -9,9 +9,11 @@
+ # 'make DEBUG=yes'.
+ #
+
++TARGET_OS ?= $(shell uname -s)
++
+ # Paths
+ # BeOS wants the libs and headers in /boot/home/config
+-ifeq (BeOS,$(shell uname -s))
++ifeq (BeOS,$(TARGET_OS))
+ prefix=/boot/home/config
+ else
+ prefix=/usr/local
+@@ -66,7 +68,7 @@ COMPILEFLAGS=$(WARNINGFLAGS) $(CXXFLAGS) $(CPPFLAGS) $(DEBUGFLAGS) $(INCLUDE)
+ DEPENDFLAGS = $(CXXFLAGS) $(INCLUDE)
+ LINKFLAGS=$(LDFLAGS)
+
+-ifeq (Darwin,$(shell uname -s))
++ifeq (Darwin,$(TARGET_OS))
+ all: staticlib
+ else
+ all: staticlib sharedlib
+@@ -116,7 +118,7 @@ depend:
+ $(CXX) $(DEPENDFLAGS) -MM -MT $$o $$i >> .depend ; \
+ done
+
+-ifeq (Darwin,$(shell uname -s))
++ifeq (Darwin,$(TARGET_OS))
+ install: install_staticlib install_headers
+ else
+ install: install_staticlib install_sharedlib install_headers
+--
+2.8.0