aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-mkv
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-multimedia/recipes-mkv
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-contrib-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-multimedia/recipes-mkv')
-rw-r--r--meta-multimedia/recipes-mkv/libebml/libebml_1.2.2.bb30
-rw-r--r--meta-multimedia/recipes-mkv/libmatroska/libmatroska_1.3.0.bb30
-rw-r--r--meta-multimedia/recipes-mkv/mkvtoolnix/mkvtoolnix_5.9.0.bb8
3 files changed, 34 insertions, 34 deletions
diff --git a/meta-multimedia/recipes-mkv/libebml/libebml_1.2.2.bb b/meta-multimedia/recipes-mkv/libebml/libebml_1.2.2.bb
index 210a409953..b66160d593 100644
--- a/meta-multimedia/recipes-mkv/libebml/libebml_1.2.2.bb
+++ b/meta-multimedia/recipes-mkv/libebml/libebml_1.2.2.bb
@@ -7,25 +7,25 @@ SRC_URI[md5sum] = "726cc2bd1a525929ff35ff9854c0ebab"
SRC_URI[sha256sum] = "476b08c6436a96c024a53e788e7c945ce9b41cd8654165763444aa7e5245b7a5"
do_compile() {
- cd ${S}/make/linux
- oe_runmake CROSS="${TARGET_PREFIX}"
+ cd ${S}/make/linux
+ oe_runmake CROSS="${TARGET_PREFIX}"
}
do_install() {
- cd ${S}/make/linux
+ cd ${S}/make/linux
- install -d ${D}${libdir}
- install -m 0644 libebml.a ${D}${libdir}
- install -m 0755 libebml.so.* ${D}${libdir}
- cp -a libebml.so ${D}${libdir}
+ install -d ${D}${libdir}
+ install -m 0644 libebml.a ${D}${libdir}
+ install -m 0755 libebml.so.* ${D}${libdir}
+ cp -a libebml.so ${D}${libdir}
- install -d ${D}${includedir}/ebml
- for i in ../../ebml/*.h; do
- install -m 0644 $i ${D}${includedir}/ebml
- done
+ install -d ${D}${includedir}/ebml
+ for i in ../../ebml/*.h; do
+ install -m 0644 $i ${D}${includedir}/ebml
+ done
- install -d ${D}${includedir}/ebml/c
- for i in ../../ebml/c/*.h; do
- install -m 0644 $i ${D}${includedir}/ebml/c
- done
+ install -d ${D}${includedir}/ebml/c
+ for i in ../../ebml/c/*.h; do
+ install -m 0644 $i ${D}${includedir}/ebml/c
+ done
}
diff --git a/meta-multimedia/recipes-mkv/libmatroska/libmatroska_1.3.0.bb b/meta-multimedia/recipes-mkv/libmatroska/libmatroska_1.3.0.bb
index 3a3dd0e957..cedd283b13 100644
--- a/meta-multimedia/recipes-mkv/libmatroska/libmatroska_1.3.0.bb
+++ b/meta-multimedia/recipes-mkv/libmatroska/libmatroska_1.3.0.bb
@@ -9,25 +9,25 @@ SRC_URI[md5sum] = "f4a8c411f09d39c754eb726efd616043"
SRC_URI[sha256sum] = "5231ec958571365e719a6fd3c220227af6cf0f14e0bd1bcf766ddbc068d18e69"
do_compile() {
- cd ${S}/make/linux
- oe_runmake CROSS="${TARGET_PREFIX}"
+ cd ${S}/make/linux
+ oe_runmake CROSS="${TARGET_PREFIX}"
}
do_install() {
- cd ${S}/make/linux
+ cd ${S}/make/linux
- install -d ${D}${libdir}
- install -m 0644 libmatroska.a ${D}${libdir}
- install -m 0755 libmatroska.so.* ${D}${libdir}
- cp -a libmatroska.so ${D}${libdir}
+ install -d ${D}${libdir}
+ install -m 0644 libmatroska.a ${D}${libdir}
+ install -m 0755 libmatroska.so.* ${D}${libdir}
+ cp -a libmatroska.so ${D}${libdir}
- install -d ${D}${includedir}/matroska
- for i in ../../matroska/*.h; do
- install -m 0644 $i ${D}${includedir}/matroska
- done
+ install -d ${D}${includedir}/matroska
+ for i in ../../matroska/*.h; do
+ install -m 0644 $i ${D}${includedir}/matroska
+ done
- install -d ${D}${includedir}/matroska/c
- for i in ../../matroska/c/*.h; do
- install -m 0644 $i ${D}${includedir}/matroska/c
- done
+ install -d ${D}${includedir}/matroska/c
+ for i in ../../matroska/c/*.h; do
+ install -m 0644 $i ${D}${includedir}/matroska/c
+ done
}
diff --git a/meta-multimedia/recipes-mkv/mkvtoolnix/mkvtoolnix_5.9.0.bb b/meta-multimedia/recipes-mkv/mkvtoolnix/mkvtoolnix_5.9.0.bb
index e7f93d2c28..13edaa95f7 100644
--- a/meta-multimedia/recipes-mkv/mkvtoolnix/mkvtoolnix_5.9.0.bb
+++ b/meta-multimedia/recipes-mkv/mkvtoolnix/mkvtoolnix_5.9.0.bb
@@ -13,18 +13,18 @@ SRC_URI[sha256sum] = "d913f531331c3332d2fb334c872ea19bfea7293dfedc4bf33ae7162e4e
inherit autotools
EXTRA_OECONF = " --with-boost-libdir=${STAGING_LIBDIR} \
- "
+"
# remove some hardcoded searchpaths
do_configure_prepend() {
- sed -i -e s:/usr/local/lib:${STAGING_LIBDIR}:g -e s:/usr/local/include:${STAGING_INCDIR}:g ac/ebml.m4
+ sed -i -e s:/usr/local/lib:${STAGING_LIBDIR}:g -e s:/usr/local/include:${STAGING_INCDIR}:g ac/ebml.m4
}
# Yeah, no makefile
do_compile() {
- ./drake
+ ./drake
}
do_install() {
- ./drake install DESTDIR=${D}
+ ./drake install DESTDIR=${D}
}