aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-multimedia/vlc/vlc.inc
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2014-07-19 21:07:37 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-22 00:01:58 +0200
commit60d945867efb496fd2030a69d0c04572939d23b3 (patch)
treea537625d1a1667935570f28873c8807272b649f1 /meta-multimedia/recipes-multimedia/vlc/vlc.inc
parentf647f319fcf1ca4844039a83fbc38acbd4ac762e (diff)
downloadmeta-openembedded-contrib-60d945867efb496fd2030a69d0c04572939d23b3.tar.gz
vlc.inc: cleanup configure, inherit pkgconfig
* Upstream is now much more pkg-config friendly * Clean up configure baggage, no longer needed Signed-off-by: Tim Orling <TicoTimo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia/vlc/vlc.inc')
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc.inc33
1 files changed, 15 insertions, 18 deletions
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc.inc b/meta-multimedia/recipes-multimedia/vlc/vlc.inc
index 58f5648211..c188771739 100644
--- a/meta-multimedia/recipes-multimedia/vlc/vlc.inc
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc.inc
@@ -5,17 +5,17 @@ SECTION = "multimedia"
LICENSE = "GPL-2.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-DEPENDS = "libfribidi libtool libgcrypt gst-plugins-bad virtual/libsdl \
- libsdl-image qt4-x11-free dbus dbus-glib libxml2 gnutls tremor \
- faad2 ffmpeg flac libxpm libxinerama fluidsynth alsa-lib libdvdcss \
- libdvdread lua-native lua libidn libnotify gtk+ gnome-vfs libdc1394 \
- libraw1394 avahi libjpeg-turbo xz libmodplug mpeg2dec \
+DEPENDS = "libfribidi libtool libgcrypt libgcrypt-native gst-plugins-bad \
+ virtual/libsdl libsdl-image qt4-x11-free dbus dbus-glib libxml2 gnutls \
+ tremor faad2 ffmpeg flac libxpm libxinerama fluidsynth alsa-lib \
+ libdvdcss libdvdread lua-native lua libidn libnotify gtk+ gnome-vfs \
+ libdc1394 libraw1394 avahi libjpeg-turbo xz libmodplug mpeg2dec \
libmtp opencv libopus orc libusb1 schroedinger taglib \
tiff xcb-util-keysyms samba"
SRC_URI = "http://download.videolan.org/pub/videolan/${BPN}/${PV}/${BP}.tar.xz"
-inherit autotools gettext
+inherit autotools gettext pkgconfig
ARM_INSTRUCTION_SET = "arm"
@@ -29,18 +29,20 @@ EXTRA_OECONF = "\
--enable-freetype \
--enable-sdl \
--enable-png \
- --enable-live555 --enable-tremor \
+ --enable-tremor \
--enable-v4l2 --disable-aa --disable-faad \
--enable-dbus \
--without-contrib \
--without-kde-solid \
--disable-glx \
--enable-realrtsp \
+ --disable-libtar \
ac_cv_path_MOC=${STAGING_BINDIR_NATIVE}/moc4 \
ac_cv_path_RCC=${STAGING_BINDIR_NATIVE}/rcc4 \
ac_cv_path_UIC=${STAGING_BINDIR_NATIVE}/uic4 \
"
+PACKAGECONFIG ?= " live555"
PACKAGECONFIG[mad] = "--enable-mad,--disable-mad,libmad"
PACKAGECONFIG[a52] = "--enable-a52,--disable-a52,liba52"
PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack"
@@ -48,18 +50,13 @@ PACKAGECONFIG[live555] = "--enable-live555,--disable-live555,live555"
PACKAGECONFIG[libass] = "--enable-libass,--disable-libass,libass"
PACKAGECONFIG[mkv] = "--enable-mkv,--disable-mkv,libmatroska libebml"
-do_configure() {
- cp ${STAGING_DATADIR}/aclocal/libgcrypt.m4 ${S}/m4/
- ./bootstrap
- gnu-configize --force
- libtoolize --force
- #autoreconf --force -i
+do_configure_prepend() {
cp ${STAGING_DATADIR}/libtool/config.* ${S}/autotools/ || true
- oe_runconf
- rm config.log
- #sed -i -e s:-L/usr/lib:-L${STAGING_LIBDIR}/:g ${S}/vlc-config
- sed -i -e s:'$(MOC) $(DEFS) $(CPPFLAGS)':'$(MOC) $(DEFS)'\ -I${S}/include\ -DSYS_LINUX:g ${S}/modules/gui/qt4/Makefile
- sed -i -e s:'${top_builddir_slash}libtool':${TARGET_SYS}-libtool:g ${S}/doltlibtool
+}
+
+do_configure_append() {
+ sed -i -e s:'$(MOC) $(DEFS) $(CPPFLAGS)':'$(MOC) $(DEFS)'\ -I${B}/include\ -DSYS_LINUX:g ${B}/modules/gui/qt4/Makefile
+ sed -i -e s:'${top_builddir_slash}libtool':${TARGET_SYS}-libtool:g ${B}/doltlibtool
}
# This recipe packages vlc as a library as well, so qt4 dependencies