aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-01-31 21:10:38 -0800
committerKhem Raj <raj.khem@gmail.com>2024-01-31 21:11:26 -0800
commit2aaf6b75a9582ee6492f65362d082969b6b1ee7d (patch)
treed5aa5286a41c9623cf2c04f40228b99e0289e10f /meta-multimedia
parent4cefe0196f7a2471b144413510d072d525e1a041 (diff)
downloadmeta-openembedded-contrib-2aaf6b75a9582ee6492f65362d082969b6b1ee7d.tar.gz
libcamera: Fix build with clang-18
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/libcamera/libcamera/0001-media_device-Add-bool-return-type-to-unlock.patch59
-rw-r--r--meta-multimedia/recipes-multimedia/libcamera/libcamera/0002-options-Replace-use-of-VLAs-in-C.patch91
-rw-r--r--meta-multimedia/recipes-multimedia/libcamera/libcamera_0.2.0.bb2
3 files changed, 152 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/libcamera/libcamera/0001-media_device-Add-bool-return-type-to-unlock.patch b/meta-multimedia/recipes-multimedia/libcamera/libcamera/0001-media_device-Add-bool-return-type-to-unlock.patch
new file mode 100644
index 0000000000..12f034effd
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/libcamera/libcamera/0001-media_device-Add-bool-return-type-to-unlock.patch
@@ -0,0 +1,59 @@
+From 6914c4fd3d53c0c6ea304123bf57429bb64ec16f Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 31 Jan 2024 21:01:27 -0800
+Subject: [PATCH 1/2] media_device: Add bool return type to unlock()
+
+unlock uses lockf which is marked with __attribute__
+((warn_unused_result)) and compilers warn about it and some treat
+-Wunused-result as error with -Werror turned on, It would be good to
+check if lockf failed or succeeded, however, that piece is not changed
+with this, this fixes build with clang++ 18
+
+ ../git/src/libcamera/media_device.cpp:167:2: error: ignoring return value of function declared with 'warn_unused_result' attribute [-Werror,-Wunused-result]
+ 167 | lockf(fd_.get(), F_ULOCK, 0);
+ | ^~~~~ ~~~~~~~~~~~~~~~~~~~~~
+ 1 error generated.
+
+Upstream-Status: Submitted [https://lists.libcamera.org/pipermail/libcamera-devel/2024-February/040380.html]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ include/libcamera/internal/media_device.h | 2 +-
+ src/libcamera/media_device.cpp | 6 +++---
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/include/libcamera/internal/media_device.h b/include/libcamera/internal/media_device.h
+index eb8cfde4..b09dfd16 100644
+--- a/include/libcamera/internal/media_device.h
++++ b/include/libcamera/internal/media_device.h
+@@ -33,7 +33,7 @@ public:
+ bool busy() const { return acquired_; }
+
+ bool lock();
+- void unlock();
++ bool unlock();
+
+ int populate();
+ bool isValid() const { return valid_; }
+diff --git a/src/libcamera/media_device.cpp b/src/libcamera/media_device.cpp
+index 2949816b..eaa2fdb0 100644
+--- a/src/libcamera/media_device.cpp
++++ b/src/libcamera/media_device.cpp
+@@ -159,12 +159,12 @@ bool MediaDevice::lock()
+ *
+ * \sa lock()
+ */
+-void MediaDevice::unlock()
++bool MediaDevice::unlock()
+ {
+ if (!fd_.isValid())
+- return;
++ return false;
+
+- lockf(fd_.get(), F_ULOCK, 0);
++ return lockf(fd_.get(), F_ULOCK, 0) == 0;
+ }
+
+ /**
+--
+2.43.0
+
diff --git a/meta-multimedia/recipes-multimedia/libcamera/libcamera/0002-options-Replace-use-of-VLAs-in-C.patch b/meta-multimedia/recipes-multimedia/libcamera/libcamera/0002-options-Replace-use-of-VLAs-in-C.patch
new file mode 100644
index 0000000000..95f321782e
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/libcamera/libcamera/0002-options-Replace-use-of-VLAs-in-C.patch
@@ -0,0 +1,91 @@
+From c80d273a57547aec9353d888aa316bf6560cf1ba Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 31 Jan 2024 21:04:28 -0800
+Subject: [PATCH 2/2] options: Replace use of VLAs in C++
+
+Clang++ 18 is fussy about this with new warning checks.
+
+ ../git/src/apps/common/options.cpp:882:20: error: variable length arrays in C++ are a Clang extension [-Werror,-Wvla-cxx-extension]
+ 882 | char shortOptions[optionsMap_.size() * 3 + 2];
+ | ^~~~~~~~~~~~~~~~~~~~~~~~~~
+
+Therefore replace using VLAs with alloca and malloc/free
+
+Upstream-Status: Submitted [https://lists.libcamera.org/pipermail/libcamera-devel/2024-February/040381.html]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/apps/common/options.cpp | 4 ++--
+ src/libcamera/ipc_unixsocket.cpp | 12 ++++++++----
+ 2 files changed, 10 insertions(+), 6 deletions(-)
+
+diff --git a/src/apps/common/options.cpp b/src/apps/common/options.cpp
+index 4f7e8691..b020f603 100644
+--- a/src/apps/common/options.cpp
++++ b/src/apps/common/options.cpp
+@@ -879,8 +879,8 @@ OptionsParser::Options OptionsParser::parse(int argc, char **argv)
+ * Allocate short and long options arrays large enough to contain all
+ * options.
+ */
+- char shortOptions[optionsMap_.size() * 3 + 2];
+- struct option longOptions[optionsMap_.size() + 1];
++ char *shortOptions = (char*)alloca(optionsMap_.size() * 3 + 2);
++ struct option *longOptions = (struct option*)alloca(optionsMap_.size() + 1);
+ unsigned int ids = 0;
+ unsigned int idl = 0;
+
+diff --git a/src/libcamera/ipc_unixsocket.cpp b/src/libcamera/ipc_unixsocket.cpp
+index 1980d374..3a7f8ee6 100644
+--- a/src/libcamera/ipc_unixsocket.cpp
++++ b/src/libcamera/ipc_unixsocket.cpp
+@@ -247,8 +247,8 @@ int IPCUnixSocket::sendData(const void *buffer, size_t length,
+ iov[0].iov_base = const_cast<void *>(buffer);
+ iov[0].iov_len = length;
+
+- char buf[CMSG_SPACE(num * sizeof(uint32_t))];
+- memset(buf, 0, sizeof(buf));
++ char *buf = (char*)malloc(CMSG_SPACE(num * sizeof(uint32_t)));
++ memset((void*)buf, 0, sizeof(buf));
+
+ struct cmsghdr *cmsg = (struct cmsghdr *)buf;
+ cmsg->cmsg_len = CMSG_LEN(num * sizeof(uint32_t));
+@@ -270,9 +270,11 @@ int IPCUnixSocket::sendData(const void *buffer, size_t length,
+ int ret = -errno;
+ LOG(IPCUnixSocket, Error)
+ << "Failed to sendmsg: " << strerror(-ret);
++ free(buf);
+ return ret;
+ }
+
++ free(buf);
+ return 0;
+ }
+
+@@ -283,8 +285,8 @@ int IPCUnixSocket::recvData(void *buffer, size_t length,
+ iov[0].iov_base = buffer;
+ iov[0].iov_len = length;
+
+- char buf[CMSG_SPACE(num * sizeof(uint32_t))];
+- memset(buf, 0, sizeof(buf));
++ char *buf = (char*)malloc(CMSG_SPACE(num * sizeof(uint32_t)));
++ memset((void*)buf, 0, sizeof(buf));
+
+ struct cmsghdr *cmsg = (struct cmsghdr *)buf;
+ cmsg->cmsg_len = CMSG_LEN(num * sizeof(uint32_t));
+@@ -305,12 +307,14 @@ int IPCUnixSocket::recvData(void *buffer, size_t length,
+ if (ret != -EAGAIN)
+ LOG(IPCUnixSocket, Error)
+ << "Failed to recvmsg: " << strerror(-ret);
++ free(buf);
+ return ret;
+ }
+
+ if (fds)
+ memcpy(fds, CMSG_DATA(cmsg), num * sizeof(uint32_t));
+
++ free(buf);
+ return 0;
+ }
+
+--
+2.43.0
+
diff --git a/meta-multimedia/recipes-multimedia/libcamera/libcamera_0.2.0.bb b/meta-multimedia/recipes-multimedia/libcamera/libcamera_0.2.0.bb
index 3fd17f0a85..5b2e863369 100644
--- a/meta-multimedia/recipes-multimedia/libcamera/libcamera_0.2.0.bb
+++ b/meta-multimedia/recipes-multimedia/libcamera/libcamera_0.2.0.bb
@@ -10,6 +10,8 @@ LIC_FILES_CHKSUM = "\
SRC_URI = " \
git://git.libcamera.org/libcamera/libcamera.git;protocol=https;branch=master \
+ file://0001-media_device-Add-bool-return-type-to-unlock.patch \
+ file://0002-options-Replace-use-of-VLAs-in-C.patch \
"
SRCREV = "89227a428a82e724548399d35c98ea89566f9045"