aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorPerceval Arenou <perceval.arenou@gmail.com>2024-04-19 14:37:27 -0700
committerKhem Raj <raj.khem@gmail.com>2024-04-19 14:39:03 -0700
commitd607d161bf6cb32c152c7841aeee622e6b92534b (patch)
tree4272b8606ef6c178a72f06712bfa502a879ca1e1 /meta-multimedia
parentb5ebed99e2185fd8deb1fa347983083f988ef7cd (diff)
downloadmeta-openembedded-contrib-d607d161bf6cb32c152c7841aeee622e6b92534b.tar.gz
aravis: new recipe
aravis is a vision library for genicam based cameras. aravis project allows to stream from genicam and GigE cameras Signed-off-by: Perceval Arenou <perceval.arenou@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/aravis/aravis_0.8.31.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/aravis/aravis_0.8.31.bb b/meta-multimedia/recipes-multimedia/aravis/aravis_0.8.31.bb
new file mode 100644
index 0000000000..b5d7772e79
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/aravis/aravis_0.8.31.bb
@@ -0,0 +1,40 @@
+SUMMARY = "A vision library for genicam based cameras"
+DESCRIPTION = "\
+ Aravis is a glib/gobject based library for video acquisition using Genicam cameras.\
+ It currently implements the gigabit ethernet and USB3 protocols used by industrial cameras.\
+ It also provides a basic ethernet camera simulator and a simple video viewer.\
+"
+AUTHOR = "Emmanuel Pacaud"
+HOMEPAGE = "https://github.com/AravisProject/aravis"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+DEPENDS += "\
+ glib-2.0 \
+ glib-2.0-native \
+ libxml2 \
+ zlib \
+"
+
+SRC_URI = "https://github.com/AravisProject/aravis/releases/download/${PV}/${BPN}-${PV}.tar.xz"
+SRC_URI[sha256sum] = "9c4ebe6273ed3abe466cb6ed8fa5c132bdd7e9a9298ca43fa0212c4311a084da"
+
+EXTRA_OEMESON += "-Dtests=false"
+
+GIR_MESON_ENABLE_FLAG = 'enabled'
+GIR_MESON_DISABLE_FLAG = 'disabled'
+GIDOCGEN_MESON_OPTION = "documentation"
+GIDOCGEN_MESON_ENABLE_FLAG = "enabled"
+GIDOCGEN_MESON_DISABLE_FLAG = "disabled"
+
+inherit meson pkgconfig gi-docgen gobject-introspection
+
+PACKAGECONFIG ?= "gstreamer usb viewer"
+PACKAGECONFIG[gstreamer] = "-Dgst-plugin=enabled, -Dgst-plugin=disabled,gstreamer1.0 gstreamer1.0-plugins-base,"
+PACKAGECONFIG[usb] = "-Dusb=enabled, -Dusb=disabled, libusb1,"
+PACKAGECONFIG[viewer] = "-Dviewer=enabled, -Dviewer=disabled, gtk+3 gstreamer1.0-plugins-base,"
+
+FILES:${PN} += "\
+ ${datadir} \
+ ${libdir}/gstreamer-1.0/libgstaravis.0.8.so \
+"