aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-11-30 22:58:35 -0800
committerKhem Raj <raj.khem@gmail.com>2023-12-01 08:47:57 -0800
commitd412f690df753abc02d0cb77330433f43e6fc446 (patch)
treebb6fdc865d7671b7e85299e100a2880dd995075c /meta-multimedia
parentdae158819f83113925d27f4d2bb11335f3e71018 (diff)
downloadmeta-openembedded-contrib-d412f690df753abc02d0cb77330433f43e6fc446.tar.gz
gstd: Fix systemd user unit packaging
We do not need to preprocess it offline as its not run per session but per user. Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb6
1 files changed, 2 insertions, 4 deletions
diff --git a/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb b/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb
index 88acdb190e..cabbf2cc11 100644
--- a/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb
+++ b/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb
@@ -17,7 +17,7 @@ PV = "1.0+really0.15.0"
GTKDOC_MESON_OPTION = "enable-gtk-doc"
-inherit meson pkgconfig gettext gtk-doc systemd python3native python3-dir python3targetconfig
+inherit meson pkgconfig gettext gtk-doc python3native python3-dir python3targetconfig
do_install:append() {
rmdir ${D}${root_prefix}${localstatedir}/run/${BPN} ${D}${root_prefix}${localstatedir}/run \
@@ -28,7 +28,7 @@ do_install:append() {
install -d ${D}${sysconfdir}/tmpfiles.d
echo "d /run/${BPN} - - - -" \
> ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf
- echo "d /${localstatedir}/log/${BPN} 0755 root root -" \
+ echo "d ${localstatedir}/log/${BPN} 0755 root root -" \
>> ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf
fi
ln -sf gst-client-1.0 ${D}${bindir}/gst-client
@@ -38,5 +38,3 @@ PACKAGES =+ "${PN}-python"
FILES:${PN} += "${systemd_user_unitdir}"
FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*"
-
-SYSTEMD_SERVICE:${PN} = "gstd.service"