aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/openconnect
diff options
context:
space:
mode:
authorMax Krummenacher <max.oss.09@gmail.com>2020-02-15 16:59:34 +0100
committerKhem Raj <raj.khem@gmail.com>2020-02-16 12:52:19 -0800
commitc24a06107d739d2496779951eeaca54f2ba9fe68 (patch)
treeabdbcf8123489b3b3ceb61151209c22e213e7994 /meta-networking/recipes-connectivity/openconnect
parent546b7900f6694a7df4d6d33c798da91d621ef393 (diff)
downloadmeta-openembedded-contrib-c24a06107d739d2496779951eeaca54f2ba9fe68.tar.gz
openconnect: build with python3
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/openconnect')
-rw-r--r--meta-networking/recipes-connectivity/openconnect/openconnect/0001-trojans-tncc-wrapper.py-convert-to-python3.patch71
-rw-r--r--meta-networking/recipes-connectivity/openconnect/openconnect_8.03.bb12
2 files changed, 76 insertions, 7 deletions
diff --git a/meta-networking/recipes-connectivity/openconnect/openconnect/0001-trojans-tncc-wrapper.py-convert-to-python3.patch b/meta-networking/recipes-connectivity/openconnect/openconnect/0001-trojans-tncc-wrapper.py-convert-to-python3.patch
new file mode 100644
index 0000000000..623ec101d3
--- /dev/null
+++ b/meta-networking/recipes-connectivity/openconnect/openconnect/0001-trojans-tncc-wrapper.py-convert-to-python3.patch
@@ -0,0 +1,71 @@
+From de78bcac5e1fd13de0371c8e14b062b8786ade56 Mon Sep 17 00:00:00 2001
+From: Max Krummenacher <max.krummenacher@toradex.com>
+Date: Sun, 2 Feb 2020 15:53:05 +0000
+Subject: [PATCH] trojans/tncc-wrapper.py: convert to python3
+
+Use 2to3 to convert the script to python3.
+
+Upstream-Status: Pending
+
+Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
+---
+ trojans/tncc-wrapper.py | 14 +++++++-------
+ 1 file changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/trojans/tncc-wrapper.py b/trojans/tncc-wrapper.py
+index 0d4587bf..1a9a1f4d 100755
+--- a/trojans/tncc-wrapper.py
++++ b/trojans/tncc-wrapper.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python2
++#!/usr/bin/python3
+
+ # Lifted from Russ Dill's juniper-vpn-wrap.py, thus:
+ #
+@@ -18,19 +18,19 @@
+
+ import subprocess
+ import mechanize
+-import cookielib
++import http.cookiejar
+ import getpass
+ import sys
+ import os
+ import zipfile
+-import urllib
++import urllib.request, urllib.parse, urllib.error
+ import socket
+ import ssl
+ import errno
+ import argparse
+ import atexit
+ import signal
+-import ConfigParser
++import configparser
+ import time
+ import binascii
+ import hmac
+@@ -39,7 +39,7 @@ import hashlib
+ def mkdir_p(path):
+ try:
+ os.mkdir(path)
+- except OSError, exc:
++ except OSError as exc:
+ if exc.errno == errno.EEXIST and os.path.isdir(path):
+ pass
+ else:
+@@ -64,9 +64,9 @@ class Tncc:
+ if zipfile.ZipFile(self.tncc_jar, 'r').testzip() is not None:
+ raise Exception()
+ except:
+- print 'Downloading tncc.jar...'
++ print('Downloading tncc.jar...')
+ mkdir_p(os.path.expanduser('~/.juniper_networks'))
+- urllib.urlretrieve('https://' + self.vpn_host
++ urllib.request.urlretrieve('https://' + self.vpn_host
+ + '/dana-cached/hc/tncc.jar', self.tncc_jar)
+
+ with zipfile.ZipFile(self.tncc_jar, 'r') as jar:
+--
+2.20.1
+
diff --git a/meta-networking/recipes-connectivity/openconnect/openconnect_8.03.bb b/meta-networking/recipes-connectivity/openconnect/openconnect_8.03.bb
index ec36a375a4..974ff45477 100644
--- a/meta-networking/recipes-connectivity/openconnect/openconnect_8.03.bb
+++ b/meta-networking/recipes-connectivity/openconnect/openconnect_8.03.bb
@@ -2,11 +2,14 @@ SUMMARY = "Open client for Cisco AnyConnect VPN"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING.LGPL;md5=243b725d71bb5df4a1e5920b344b86ad"
-SRC_URI = "git://git.infradead.org/users/dwmw2/openconnect.git"
+SRC_URI = " \
+ git://git.infradead.org/users/dwmw2/openconnect.git \
+ file://0001-trojans-tncc-wrapper.py-convert-to-python3.patch \
+"
SRCREV = "ea73851969ae7a6ea54fdd2d2b8c94776af24b2a"
DEPENDS = "vpnc libxml2 krb5 gettext-native"
-RDEPENDS_${PN} = "bash python"
+RDEPENDS_${PN} = "bash python3-core"
PACKAGECONFIG ??= "gnutls lz4 libproxy"
@@ -24,8 +27,3 @@ inherit autotools pkgconfig
EXTRA_OECONF += "--with-vpnc-script=${SYSROOT_DESTDIR}${sysconfdir}/vpnc/vpnc-script \
--disable-static"
-
-do_configure_append() {
- # script has /usr/bin/python2 path hardcoded
- sed -i -e 's=python2\.*=python=g' ${S}/trojans/tncc-wrapper.py
-}