aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2021-02-06 22:43:59 +0100
committerKhem Raj <raj.khem@gmail.com>2021-02-06 13:53:09 -0800
commit225a957ba502e5a3edfa6f924defdf17bcc5c82c (patch)
treef2475b71ab5e6a2c06aafe4b37231be6421635bb /meta-networking/recipes-connectivity
parent8f21c1209b9c9e01ad6c5aca992f1ed92271defa (diff)
downloadmeta-openembedded-contrib-225a957ba502e5a3edfa6f924defdf17bcc5c82c.tar.gz
cannelloni: update to 1.0.0
Removed upstreamed patches. Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/cannelloni/cannelloni/0001-Use-GNUInstallDirs-instead-of-hard-coding-paths.patch43
-rw-r--r--meta-networking/recipes-connectivity/cannelloni/cannelloni/0002-include-missing-stdexcept-for-runtime_error.patch32
-rw-r--r--meta-networking/recipes-connectivity/cannelloni/cannelloni_1.0.0.bb (renamed from meta-networking/recipes-connectivity/cannelloni/cannelloni_git.bb)9
3 files changed, 2 insertions, 82 deletions
diff --git a/meta-networking/recipes-connectivity/cannelloni/cannelloni/0001-Use-GNUInstallDirs-instead-of-hard-coding-paths.patch b/meta-networking/recipes-connectivity/cannelloni/cannelloni/0001-Use-GNUInstallDirs-instead-of-hard-coding-paths.patch
deleted file mode 100644
index b78f0b3291..0000000000
--- a/meta-networking/recipes-connectivity/cannelloni/cannelloni/0001-Use-GNUInstallDirs-instead-of-hard-coding-paths.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From c74f04dbab4d586287347b1d5517f36e2f0c3d8e Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 19 Dec 2019 15:52:34 -0800
-Subject: [PATCH] Use GNUInstallDirs instead of hard-coding paths
-
-Bump minimum cmake version to be >= 3.1
-
-Upstream-Status: Submitted [https://github.com/mguentner/cannelloni/pull/22]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- CMakeLists.txt | 8 +++++---
- 1 file changed, 5 insertions(+), 3 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 51b354f..958e0eb 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -1,4 +1,4 @@
--cmake_minimum_required(VERSION 2.6)
-+cmake_minimum_required(VERSION 3.1)
- project(cannelloni)
-
- list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules")
-@@ -60,6 +60,8 @@ set_target_properties ( cannelloni-common
- SOVERSION 0
- )
-
-+include(GNUInstallDirs)
-+
- if(SCTP_SUPPORT)
- add_library(sctpthread STATIC sctpthread.cpp)
- target_link_libraries(sctpthread addsources sctp)
-@@ -68,5 +70,5 @@ endif(SCTP_SUPPORT)
- set_target_properties(addsources PROPERTIES LIBRARY_OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR})
- target_link_libraries(cannelloni addsources cannelloni-common pthread)
-
--install(TARGETS cannelloni DESTINATION bin)
--install(TARGETS cannelloni-common DESTINATION lib)
-+install(TARGETS cannelloni DESTINATION ${CMAKE_INSTALL_BINDIR})
-+install(TARGETS cannelloni-common DESTINATION ${CMAKE_INSTALL_LIBDIR})
---
-2.24.1
-
diff --git a/meta-networking/recipes-connectivity/cannelloni/cannelloni/0002-include-missing-stdexcept-for-runtime_error.patch b/meta-networking/recipes-connectivity/cannelloni/cannelloni/0002-include-missing-stdexcept-for-runtime_error.patch
deleted file mode 100644
index 55f28dd672..0000000000
--- a/meta-networking/recipes-connectivity/cannelloni/cannelloni/0002-include-missing-stdexcept-for-runtime_error.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 1788762863cd1f657697575f6e73a22e661ccb43 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Mon, 23 Dec 2019 10:32:54 -0800
-Subject: [PATCH 2/2] include missing <stdexcept> for runtime_error
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Fixes
-error: ‘runtime_error’ is not a member of ‘std’
-
-Upstream-Status: Submitted [https://github.com/mguentner/cannelloni/pull/22]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- parser.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/parser.cpp b/parser.cpp
-index 4afb9e0..5bcdbde 100644
---- a/parser.cpp
-+++ b/parser.cpp
-@@ -2,6 +2,7 @@
-
- #include <arpa/inet.h>
- #include <string.h>
-+#include <stdexcept>
-
- void parseFrames(uint16_t len, const uint8_t* buffer, std::function<canfd_frame*()> frameAllocator,
- std::function<void(canfd_frame*, bool)> frameReceiver)
---
-2.24.1
-
diff --git a/meta-networking/recipes-connectivity/cannelloni/cannelloni_git.bb b/meta-networking/recipes-connectivity/cannelloni/cannelloni_1.0.0.bb
index d4a62bd92d..0cf57ccdb7 100644
--- a/meta-networking/recipes-connectivity/cannelloni/cannelloni_git.bb
+++ b/meta-networking/recipes-connectivity/cannelloni/cannelloni_1.0.0.bb
@@ -2,13 +2,8 @@ SUMMARY = "a SocketCAN over Ethernet tunnel"
HOMEPAGE = "https://github.com/mguentner/cannelloni"
LICENSE = "GPLv2"
-SRC_URI = "git://github.com/mguentner/cannelloni.git;protocol=https \
- file://0001-Use-GNUInstallDirs-instead-of-hard-coding-paths.patch \
- file://0002-include-missing-stdexcept-for-runtime_error.patch \
- "
-SRCREV = "82aa49b417b96fe46bb3f017ae1bfea928f20f9a"
-
-PV = "20160414+${SRCPV}"
+SRC_URI = "git://github.com/mguentner/cannelloni.git;protocol=https"
+SRCREV = "0bd7e27db35bdef361226882ae04205504f7b2f4"
LIC_FILES_CHKSUM = "file://gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"