aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorStefan Wiehler <stefan.wiehler@missinglinkelectronics.com>2021-05-12 15:08:41 +0200
committerKhem Raj <raj.khem@gmail.com>2021-05-12 07:11:41 -0700
commitc049a4e2cee70c023596ec031fa55f479a74afa1 (patch)
tree850392b34ff9f571b51671ecf55c293db1e7d7cd /meta-networking/recipes-connectivity
parent6f47ea50610d760a8f84106f8ea7d582a96ddf02 (diff)
downloadmeta-openembedded-contrib-c049a4e2cee70c023596ec031fa55f479a74afa1.tar.gz
restinio: add recipe
Header-only C++14 library that gives you an embedded HTTP server. Signed-off-by: Stefan Wiehler <stefan.wiehler@missinglinkelectronics.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/restinio/restinio_0.6.13.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/restinio/restinio_0.6.13.bb b/meta-networking/recipes-connectivity/restinio/restinio_0.6.13.bb
new file mode 100644
index 0000000000..ec9b056e5d
--- /dev/null
+++ b/meta-networking/recipes-connectivity/restinio/restinio_0.6.13.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Header-only C++14 library that gives you an embedded HTTP server"
+DESCRIPTION = "Cross-platform, efficient, customizable, and robust \
+ asynchronous HTTP/WebSocket server C++14 library with the \
+ right balance between performance and ease of use"
+AUTHOR = "Stefan Wiehler <stefan.wiehler@missinglinkelectronics.com>"
+HOMEPAGE = "https://stiffstream.com/en/products/restinio.html"
+SECTION = "libs"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://../LICENSE;md5=f399b62ce0a152525d1589a5a40c0ff6"
+DEPENDS = "asio fmt http-parser"
+
+SRC_URI = "https://github.com/Stiffstream/restinio/releases/download/v.${PV}/restinio-${PV}.tar.bz2"
+SRC_URI[md5sum] = "37a4310e98912030a74bdd4ed789f33c"
+SRC_URI[sha256sum] = "b35d696e6fafd4563ca708fcecf9d0cf6705c846d417b5000f5252e0188848e7"
+
+S = "${WORKDIR}/${PN}-${PV}/dev"
+
+inherit cmake
+
+EXTRA_OECMAKE += "\
+ -DRESTINIO_TEST=OFF \
+ -DRESTINIO_SAMPLE=OFF \
+ -DRESTINIO_BENCH=OFF \
+ -DRESTINIO_FIND_DEPS=ON \
+ -DRESTINIO_ALLOW_SOBJECTIZER=OFF \
+ -DRESTINIO_USE_EXTERNAL_HTTP_PARSER=ON \
+ "
+
+# Header-only library
+RDEPENDS_${PN}-dev = ""
+RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"