aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-05-26 21:47:54 -0700
committerKhem Raj <raj.khem@gmail.com>2021-05-28 06:55:33 -0700
commit827f51176517219b9d0f7f6783970edc9079a5a5 (patch)
treed6689e225d9b42ccb13feccfc14f9ea52a9db382 /meta-networking/recipes-connectivity
parentccc9d946e39a3d9841296662656df2c697f23689 (diff)
downloadmeta-openembedded-contrib-827f51176517219b9d0f7f6783970edc9079a5a5.tar.gz
dhcp-relay: Use recent config.guess and config.sub for bind
vendored version of bind is quite old which does not have all newer architecture info like riscv in gnu-config files captured in the bind tarball, therefore update these files before configuring bundled bind Fixes build on rv32/rv64 Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Yi Zhao <yi.zhao@windriver.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2.bb b/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2.bb
index bd816106c5..2af41b217a 100644
--- a/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2.bb
+++ b/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2.bb
@@ -43,6 +43,12 @@ EXTRA_OECONF = "--enable-paranoia \
do_configure_prepend () {
cp configure.ac+lt configure.ac
}
+do_compile_prepend() {
+ rm -rf ${S}/bind/bind-9.11.14/
+ tar xf ${S}/bind/bind.tar.gz -C ${S}/bind
+ install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/bind/bind-9.11.14/
+ install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/bind/bind-9.11.14/
+}
do_install_append () {
install -d ${D}${sysconfdir}/default