aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons
diff options
context:
space:
mode:
authorBartosz Golaszewski <bgolaszewski@baylibre.com>2019-10-11 00:34:29 +0200
committerKhem Raj <raj.khem@gmail.com>2019-10-10 21:58:10 -0700
commit8887455a442aa5377ebef9d84d0c61884540154a (patch)
tree829d1b9b02a47ad795d8280174805ec8be7f9641 /meta-networking/recipes-daemons
parent667e76f853d04ec5869b40213b1aeeee5461c59e (diff)
downloadmeta-openembedded-contrib-8887455a442aa5377ebef9d84d0c61884540154a.tar.gz
networkd-dispatcher: inherit systemd class
Use the systemd class to correctly plug the package into the systemd infrastructure. Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-daemons')
-rw-r--r--meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.0.1.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.0.1.bb b/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.0.1.bb
index 06c83e9d80..8523ae8c0d 100644
--- a/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.0.1.bb
+++ b/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.0.1.bb
@@ -7,7 +7,7 @@ AUTHOR = "Clayton Craft and others"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d"
-inherit distro_features_check
+inherit distro_features_check systemd
RDEPENDS_${PN} = "python3-pygobject python3-dbus"
REQUIRED_DISTRO_FEATURES = "systemd"
@@ -16,6 +16,10 @@ SRC_URI = "https://gitlab.com/craftyguy/networkd-dispatcher/-/archive/${PV}/netw
SRC_URI[md5sum] = "304d7dcc21331ea295e207f8493cb8d8"
SRC_URI[sha256sum] = "21f84c3646a043329dc64787e4e58dfce592b2559b0e3069af82c469805660c2"
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "networkd-dispatcher.service"
+SYSTEMD_AUTO_ENABLE = "disable"
+
# Nothing to build, just a python script to install
do_configure[noexec] = "1"
do_compile[noexec] = "1"
@@ -25,5 +29,3 @@ do_install() {
install -D -m 0644 ${S}/networkd-dispatcher.service ${D}/${systemd_system_unitdir}/networkd-dispatcher.service
install -D -m 0644 ${S}/networkd-dispatcher.conf ${D}/${sysconfdir}/conf.d/networkd-dispatcher.conf
}
-
-FILES_${PN} += "${systemd_system_unitdir}/networkd-dispatcher.service"