aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-filter/nftables/nftables_0.9.6.bb
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2020-06-30 09:24:09 +0800
committerArmin Kuster <akuster808@gmail.com>2020-07-12 19:20:37 -0700
commit7ed1adba7993bf3d619cb5bcb4f77ace9ea247ff (patch)
tree938fe01eb530607f801ea940911738f48f69e06d /meta-networking/recipes-filter/nftables/nftables_0.9.6.bb
parentb1b6f976aae12df18fb3aa5432b405e2c4431103 (diff)
downloadmeta-openembedded-contrib-7ed1adba7993bf3d619cb5bcb4f77ace9ea247ff.tar.gz
nftables: upgrade 0.9.5 -> 0.9.6
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit b0d884a994197a9bc0b181545fe67f19a7630cd7) [AK: This release fixes vmap support which broke in the previous 0.9.5 release.] Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking/recipes-filter/nftables/nftables_0.9.6.bb')
-rw-r--r--meta-networking/recipes-filter/nftables/nftables_0.9.6.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-networking/recipes-filter/nftables/nftables_0.9.6.bb b/meta-networking/recipes-filter/nftables/nftables_0.9.6.bb
new file mode 100644
index 0000000000..41f7f4c91c
--- /dev/null
+++ b/meta-networking/recipes-filter/nftables/nftables_0.9.6.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Netfilter Tables userspace utillites"
+SECTION = "net"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d1a78fdd879a263a5e0b42d1fc565e79"
+
+DEPENDS = "libmnl libnftnl bison-native \
+ ${@bb.utils.contains('PACKAGECONFIG', 'mini-gmp', '', 'gmp', d)}"
+
+# Ensure we reject the 0.099 version by matching at least two dots
+UPSTREAM_CHECK_REGEX = "nftables-(?P<pver>\d+(\.\d+){2,}).tar.bz2"
+
+SRC_URI = "http://www.netfilter.org/projects/nftables/files/${BP}.tar.bz2"
+SRC_URI[sha256sum] = "68d6fdfe8ab02303e6b1f13968a4022da5b0120110eaee3233d806857937b66e"
+
+inherit autotools manpages pkgconfig
+
+PACKAGECONFIG ??= "python readline"
+PACKAGECONFIG[json] = "--with-json, --without-json, jansson"
+PACKAGECONFIG[manpages] = "--enable-man-doc, --disable-man-doc, asciidoc-native"
+PACKAGECONFIG[mini-gmp] = "--with-mini-gmp, --without-mini-gmp"
+PACKAGECONFIG[python] = "--enable-python --with-python-bin=${PYTHON}, --with-python-bin="", python3"
+PACKAGECONFIG[readline] = "--with-cli=readline, --without-cli, readline"
+PACKAGECONFIG[xtables] = "--with-xtables, --without-xtables, iptables"
+
+inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)}
+
+RRECOMMENDS_${PN} += "kernel-module-nf-tables"
+
+PACKAGES =+ "${PN}-python"
+FILES_${PN}-python = "${nonarch_libdir}/${PYTHON_DIR}"
+RDEPENDS_${PN}-python = "python3-core python3-json"