aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20200401.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-04-07 18:48:23 -0700
committerKhem Raj <raj.khem@gmail.com>2020-04-07 18:50:59 -0700
commitce2c3a2f51efbb1d1d9873c118eacbacfa5a2c96 (patch)
treefc517be31944ef4a3ff4419a2d5b3da72b3d4688 /meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20200401.bb
parentc9ef43adeb767fba9e56bb1005f3c19341d34152 (diff)
downloadmeta-openembedded-contrib-ce2c3a2f51efbb1d1d9873c118eacbacfa5a2c96.tar.gz
wireguard: Upgrade to latest compat external module and tools
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20200401.bb')
-rw-r--r--meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20200401.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20200401.bb b/meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20200401.bb
new file mode 100644
index 0000000000..73199592c8
--- /dev/null
+++ b/meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20200401.bb
@@ -0,0 +1,35 @@
+require wireguard.inc
+
+SRCREV = "43f57dac7b8305024f83addc533c9eede6509129"
+
+SRC_URI = "git://git.zx2c4.com/wireguard-linux-compat"
+
+inherit module kernel-module-split
+
+DEPENDS = "virtual/kernel libmnl"
+
+# This module requires Linux 3.10 higher and several networking related
+# configuration options. For exact kernel requirements visit:
+# https://www.wireguard.io/install/#kernel-requirements
+
+EXTRA_OEMAKE_append = " \
+ KERNELDIR=${STAGING_KERNEL_DIR} \
+ "
+
+MAKE_TARGETS = "module"
+
+RRECOMMENDS_${PN} = "kernel-module-xt-hashlimit"
+MODULE_NAME = "wireguard"
+
+# Kernel module packages MUST begin with 'kernel-module-', otherwise
+# multilib image generation can fail.
+#
+# The following line is only necessary if the recipe name does not begin
+# with kernel-module-.
+PKG_${PN} = "kernel-module-${MODULE_NAME}"
+
+module_do_install() {
+ install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}
+ install -m 0644 ${MODULE_NAME}.ko \
+ ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}/${MODULE_NAME}.ko
+}