aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-kernel/wireguard/wireguard-tools_0.0.20170421.bb
diff options
context:
space:
mode:
authorStefan Agner <stefan@agner.ch>2017-04-26 22:30:21 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2017-04-27 12:02:13 -0400
commit9867ffa48e2a4001fa743e5a0b9a96074da46ffb (patch)
tree8686ce446fbafc914b41759ae3d6bb329a85a80a /meta-networking/recipes-kernel/wireguard/wireguard-tools_0.0.20170421.bb
parent57d3b5c5c8e6b649f0b029ce5a2a4c51387e3882 (diff)
downloadmeta-openembedded-contrib-9867ffa48e2a4001fa743e5a0b9a96074da46ffb.tar.gz
wireguard: add WireGuard kernel module and tools
WireGuard is an extremely simple yet fast and modern VPN that utilizes state-of-the-art cryptography. It aims to be faster, simpler, leaner, and more useful than IPSec, while avoiding the massive headache. The recipes add the current experimental snapshot v0.0.20170421 out-of-tree kernel module and tools. The kernel module has some kernel configuration dependencies such as some configuration part of features/netfilter/netfilter.scc, hence netfilter.scc should be part of KERNEL_EXTRA_FEATURES (which is the case by default). Since wireguard-tools is TUNE_PKGARCH and depends on wireguard-module which is MACHINE_ARCH (like all kernel modules) we need to add this dependency to SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS. Signed-off-by: Stefan Agner <stefan@agner.ch> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-kernel/wireguard/wireguard-tools_0.0.20170421.bb')
-rw-r--r--meta-networking/recipes-kernel/wireguard/wireguard-tools_0.0.20170421.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-networking/recipes-kernel/wireguard/wireguard-tools_0.0.20170421.bb b/meta-networking/recipes-kernel/wireguard/wireguard-tools_0.0.20170421.bb
new file mode 100644
index 0000000000..79d420f1a4
--- /dev/null
+++ b/meta-networking/recipes-kernel/wireguard/wireguard-tools_0.0.20170421.bb
@@ -0,0 +1,27 @@
+require wireguard.inc
+
+inherit bash-completion systemd pkgconfig
+
+DEPENDS = "wireguard-module libmnl"
+
+do_compile_prepend () {
+ cd ${S}/tools
+}
+
+do_install () {
+ cd ${S}/tools
+ oe_runmake DESTDIR="${D}" PREFIX="${prefix}" SYSCONFDIR="${sysconfdir}" \
+ SYSTEMDUNITDIR="${systemd_unitdir}" \
+ WITH_SYSTEMDUNITS=${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'yes', '', d)} \
+ WITH_BASHCOMPLETION=yes \
+ WITH_WGQUICK=yes \
+ install
+}
+
+FILES_${PN} = " \
+ ${sysconfdir} \
+ ${systemd_unitdir} \
+ ${bindir} \
+"
+
+RDEPENDS_${PN} = "wireguard-module"