aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-protocols
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2013-11-21 11:27:40 +0800
committerJoe MacDonald <joe@deserted.net>2013-11-27 15:20:06 -0500
commit75c52163b0f6e847f178d5919678f3c2af6f273f (patch)
tree4177a028e8d4a980f7ffdb0e97748444bdf4aecf /meta-networking/recipes-protocols
parentec152778cd6cc670991445d02e35685e6e3404ed (diff)
downloadmeta-openembedded-contrib-75c52163b0f6e847f178d5919678f3c2af6f273f.tar.gz
quagga: Backport a patch to fix extract.pl for cross compilation
Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Joe MacDonald <joe@deserted.net>
Diffstat (limited to 'meta-networking/recipes-protocols')
-rw-r--r--meta-networking/recipes-protocols/quagga/files/build-fix-extract.pl-for-cross-compilation.patch31
-rw-r--r--meta-networking/recipes-protocols/quagga/quagga_0.99.21.bb4
2 files changed, 34 insertions, 1 deletions
diff --git a/meta-networking/recipes-protocols/quagga/files/build-fix-extract.pl-for-cross-compilation.patch b/meta-networking/recipes-protocols/quagga/files/build-fix-extract.pl-for-cross-compilation.patch
new file mode 100644
index 0000000000..e3ccc2a0ed
--- /dev/null
+++ b/meta-networking/recipes-protocols/quagga/files/build-fix-extract.pl-for-cross-compilation.patch
@@ -0,0 +1,31 @@
+Upstream-Status: Backport
+
+From ed6e297972318a0070ad4d973401fbc6e0def558 Mon Sep 17 00:00:00 2001
+From: Serj Kalichev <serj.kalichev@gmail.com>
+Date: Fri, 7 Sep 2012 13:29:42 +0400
+Subject: [PATCH] build: fix extract.pl for cross compilation
+
+extract.pl should invoke the C preprocessor for the target system, not the
+host.
+
+* vtysh/extract.pl.in: use @CPP@ to get target cpp
+---
+ vtysh/extract.pl.in | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/vtysh/extract.pl.in b/vtysh/extract.pl.in
+index 7612aff..4c3a47f 100755
+--- a/vtysh/extract.pl.in
++++ b/vtysh/extract.pl.in
+@@ -63,7 +63,7 @@ $ignore{'"show history"'} = "ignore";
+ foreach (@ARGV) {
+ $file = $_;
+
+- open (FH, "cpp -DHAVE_CONFIG_H -DVTYSH_EXTRACT_PL -DHAVE_IPV6 -I@top_builddir@ -I@srcdir@/ -I@srcdir@/.. -I@top_srcdir@/lib -I@top_srcdir@/isisd/topology @SNMP_INCLUDES@ @CPPFLAGS@ $file |");
++ open (FH, "@cpp@ -DHAVE_CONFIG_H -DVTYSH_EXTRACT_PL -DHAVE_IPV6 -I@top_builddir@ -I@srcdir@/ -I@srcdir@/.. -I@top_srcdir@/lib -I@top_srcdir@/isisd/topology @SNMP_INCLUDES@ @CPPFLAGS@ $file |");
+ local $/; undef $/;
+ $line = <FH>;
+ close (FH);
+--
+1.7.1
+
diff --git a/meta-networking/recipes-protocols/quagga/quagga_0.99.21.bb b/meta-networking/recipes-protocols/quagga/quagga_0.99.21.bb
index 10740bc802..ae93952e3e 100644
--- a/meta-networking/recipes-protocols/quagga/quagga_0.99.21.bb
+++ b/meta-networking/recipes-protocols/quagga/quagga_0.99.21.bb
@@ -3,7 +3,9 @@ require quagga.inc
PR = "${INC_PR}.0"
SRC_URI += "file://0001-doc-fix-makeinfo-errors-and-one-warning.patch \
- file://lingering-IP-address-after-deletion-BZ-486.patch"
+ file://lingering-IP-address-after-deletion-BZ-486.patch \
+ file://build-fix-extract.pl-for-cross-compilation.patch \
+"
SRC_URI[quagga-0.99.21.md5sum] = "99840adbe57047c90dfba6b6ed9aec7f"
SRC_URI[quagga-0.99.21.sha256sum] = "9b8aea9026b4771a28e254a66cbd854723bcd0d71eebd0201d11838d4eb392ee"