aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-protocols
diff options
context:
space:
mode:
authorAlexandre Fournier <alexandre.fournier@kiplink.fr>2014-05-22 14:36:47 +0200
committerJoe MacDonald <joe@deserted.net>2014-06-03 21:18:51 -0400
commitc4ba56ceebdd0d42f90e2ec509440f105645c376 (patch)
treeeacd55b69b54eb859404d0bf60ee201393c59c2f /meta-networking/recipes-protocols
parent9d49c83415d5233ac17d68d21fb5fd6a91085593 (diff)
downloadmeta-openembedded-contrib-c4ba56ceebdd0d42f90e2ec509440f105645c376.tar.gz
net-snmp: install net-snmp-config script to STAGING_BINDIR_CROSS
This recipe was installing net-snmp-config script to STAGING_BINDIR instead of STAGING_BINDIR_CROSS, during the do_install. It is not recommended and must be done after staging. Changes: * Remove STAGING_BINDIR manipulations from do_install_append * Add net_snmp_sysroot_preprocess function instead * Append net_snmp_sysroot_preprocess to SYSROOT_PREPROCESS_FUNCS Signed-off-by: Alexandre Fournier <alexandre.fournier@kiplink.fr> Signed-off-by: Joe MacDonald <joe@deserted.net>
Diffstat (limited to 'meta-networking/recipes-protocols')
-rw-r--r--meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.2.bb13
1 files changed, 10 insertions, 3 deletions
diff --git a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.2.bb b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.2.bb
index eb50d0fd44..f1e3a5d349 100644
--- a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.2.bb
+++ b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.2.bb
@@ -49,19 +49,26 @@ do_install_append() {
install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/snmpd
install -m 644 ${WORKDIR}/snmpd.conf ${D}${sysconfdir}/snmp/
install -m 644 ${WORKDIR}/snmptrapd.conf ${D}${sysconfdir}/snmp/
- install -d ${STAGING_BINDIR}
- install -m 0755 ${D}${bindir}/net-snmp-config ${STAGING_BINDIR}/
sed -e "s@-I/usr/include@@g" \
-e "s@^prefix=.*@prefix=${STAGING_DIR_HOST}@g" \
-e "s@^exec_prefix=.*@exec_prefix=${STAGING_DIR_HOST}@g" \
-e "s@^includedir=.*@includedir=${STAGING_INCDIR}@g" \
-e "s@^libdir=.*@libdir=${STAGING_LIBDIR}@g" \
- -i ${STAGING_BINDIR}/net-snmp-config
+ -i ${D}${bindir}/net-snmp-config
install -d ${D}${systemd_unitdir}/system
install -m 0644 ${WORKDIR}/snmpd.service ${D}${systemd_unitdir}/system
install -m 0644 ${WORKDIR}/snmptrapd.service ${D}${systemd_unitdir}/system
}
+SYSROOT_PREPROCESS_FUNCS += "net_snmp_sysroot_preprocess"
+
+net_snmp_sysroot_preprocess () {
+ if [ -e ${D}${bindir}/net-snmp-config ]; then
+ install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
+ install -m 755 ${D}${bindir}/net-snmp-config ${SYSROOT_DESTDIR}${bindir_crossscripts}/
+ fi
+}
+
PACKAGES = "${PN}-dbg ${PN}-doc ${PN}-dev ${PN}-staticdev ${PN}-static ${PN}-libs \
${PN}-mibs ${PN}-server ${PN}-client ${PN}-server-snmpd ${PN}-server-snmptrapd"