aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/arptables
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2013-02-14 13:40:04 -0800
committerJoe MacDonald <joe.macdonald@windriver.com>2013-02-14 22:49:03 -0500
commit5346f2f092e6f6d52bbb225f482fbe054bdbe19b (patch)
tree8134498e93006300ea0e80927ecd9f1e646d77e5 /meta-networking/recipes-support/arptables
parenta3f1c77cf5d7d350502ff6eb1784fbf432ea6fc5 (diff)
downloadmeta-openembedded-contrib-5346f2f092e6f6d52bbb225f482fbe054bdbe19b.tar.gz
arptables: defeat multi-job for install
CQID: 399299 The make install target is not parallel job safe, but doesn't do all that much, so we limit make to one job for that. The make target is of the form install: x y z Unfortunately, z depends on y, so if z is started before y (almost) completes, we will fail. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
Diffstat (limited to 'meta-networking/recipes-support/arptables')
-rw-r--r--meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb b/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb
index 2faccec7d5..86b900a5da 100644
--- a/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb
+++ b/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb
@@ -3,6 +3,8 @@ PRIORITY = "optional"
LICENSE = "GPL-2.0"
SECTION = "console/network"
+PR = "r2"
+
RDEPENDS_${PN} += "perl"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
@@ -20,6 +22,11 @@ do_compile () {
oe_runmake
}
+# the install target is not multi-job safe, but it doesn't do much
+# so we just install serially
+#
+PARALLEL_MAKEINST = "-j1"
+
fakeroot do_install () {
oe_runmake 'BINDIR=${sbindir}' 'MANDIR=${mandir}/' 'DESTDIR=${D}' install
}