aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/arptables
diff options
context:
space:
mode:
authorRoy.Li <rongqing.li@windriver.com>2013-06-17 15:04:00 +0800
committerJoe MacDonald <joe.macdonald@windriver.com>2013-06-17 09:50:53 -0400
commita4c953b35d082c9ef45c6e41212bf9c8f7b0ff74 (patch)
tree7aeb662ef33c2cdce0703cb5a4115ab31bddbb7e /meta-networking/recipes-support/arptables
parente34f1f1ad765a324116dfb296895cd4276230487 (diff)
downloadmeta-openembedded-contrib-a4c953b35d082c9ef45c6e41212bf9c8f7b0ff74.tar.gz
arptables: fix the redefinition of 'arpt_get_target' error
Signed-off-by: Roy.Li <rongqing.li@windriver.com> Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
Diffstat (limited to 'meta-networking/recipes-support/arptables')
-rw-r--r--meta-networking/recipes-support/arptables/arptables-0.0.3-4/arptables-arpt-get-target-fix.patch30
-rw-r--r--meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb1
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/arptables/arptables-0.0.3-4/arptables-arpt-get-target-fix.patch b/meta-networking/recipes-support/arptables/arptables-0.0.3-4/arptables-arpt-get-target-fix.patch
new file mode 100644
index 0000000000..0875344feb
--- /dev/null
+++ b/meta-networking/recipes-support/arptables/arptables-0.0.3-4/arptables-arpt-get-target-fix.patch
@@ -0,0 +1,30 @@
+arptables: fix the redefinition of 'arpt_get_target'
+
+Upstream-Status: Pending
+
+This function is already defined as a static inline function in
+include/linux/netfilter_arp/arp_tables.h, once GCC uses -O0, the
+inline will not work, and the redefinition error will happen
+
+Signed-off-by: Aws Ismail <aws.ismail@windriver.com>
+Signed-off-by: Roy.Li <rongqing.li@windriver.com>
+
+diff --git a/libarptc/libarptc_incl.c b/libarptc/libarptc_incl.c
+index 35736db..addd3f9 100644
+--- a/libarptc/libarptc_incl.c
++++ b/libarptc/libarptc_incl.c
+@@ -11,14 +11,6 @@
+ /* (C)1999 Paul ``Rusty'' Russell - Placed under the GNU GPL (See
+ COPYING for details). */
+
+-#ifndef __OPTIMIZE__
+-STRUCT_ENTRY_TARGET *
+-GET_TARGET(STRUCT_ENTRY *e)
+-{
+- return (void *)e + e->target_offset;
+-}
+-#endif
+-
+ static int sockfd = -1;
+ static void *arptc_fn = NULL;
+
diff --git a/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb b/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb
index fe14b61e11..f3deaeb5dc 100644
--- a/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb
+++ b/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb
@@ -12,6 +12,7 @@ SRC_URI = " \
${SOURCEFORGE_MIRROR}/ebtables/arptables-v${PV}.tar.gz;name=arptables \
file://arptables-compile-install.patch \
file://arptables-init-busybox.patch \
+ file://arptables-arpt-get-target-fix.patch \
"
SRC_URI[arptables.md5sum] = "1d4ab05761f063b0751645d8f2b8f8e5"
SRC_URI[arptables.sha256sum] = "e529fd465c67d69ad335299a043516e6b38cdcd337a5ed21718413e96073f928"