aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/chrony
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2016-08-24 17:06:49 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2016-09-05 13:34:11 -0400
commitd4b6c7df767f3eca5dbcb0597f0790013791dd0b (patch)
tree435f1de28dfdd54e9f0ed5e27746d9940e9d5755 /meta-networking/recipes-support/chrony
parentc13a7062c9e8a9cdffab1576fe00fa7a485bf47c (diff)
downloadmeta-openembedded-contrib-d4b6c7df767f3eca5dbcb0597f0790013791dd0b.tar.gz
chrony: control ipv6 support based on DISTRO_FEATURES
Add PACKAGECONFIG for ipv6 and control it based on DISTRO_FEATURES. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/chrony')
-rw-r--r--meta-networking/recipes-support/chrony/chrony_2.4.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/chrony/chrony_2.4.bb b/meta-networking/recipes-support/chrony/chrony_2.4.bb
index 9698ae418c..4bc4ce0df1 100644
--- a/meta-networking/recipes-support/chrony/chrony_2.4.bb
+++ b/meta-networking/recipes-support/chrony/chrony_2.4.bb
@@ -58,12 +58,15 @@ inherit update-rc.d systemd
# chrony.conf and init script.
# - 'scfilter' enables support for system call filtering, but requires the
# kernel to have CONFIG_SECCOMP enabled.
-PACKAGECONFIG ??= "editline scfilter"
+PACKAGECONFIG ??= "editline scfilter \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)} \
+"
PACKAGECONFIG[readline] = "--without-editline,--without-readline,readline"
PACKAGECONFIG[editline] = ",--without-editline,libedit"
PACKAGECONFIG[sechash] = "--without-tomcrypt,--disable-sechash,nss"
PACKAGECONFIG[privdrop] = ",--disable-privdrop,libcap"
PACKAGECONFIG[scfilter] = "--enable-scfilter,--without-seccomp"
+PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
# --disable-static isn't supported by chrony's configure script.
DISABLE_STATIC = ""