aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/curlpp
diff options
context:
space:
mode:
authorQi.Chen@windriver.com <Qi.Chen@windriver.com>2016-07-19 16:22:44 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2016-08-05 09:06:50 -0400
commitfa2c10caebb42b3bcd83668129e65206bc443079 (patch)
tree10650d0def22db56c3dc797a5a84aa336ad27d47 /meta-networking/recipes-support/curlpp
parent3683e46e050906a58c5507a9aa51458bf36c4d7c (diff)
downloadmeta-openembedded-contrib-fa2c10caebb42b3bcd83668129e65206bc443079.tar.gz
curlpp: fix QA issue for cav-octeon3
Modify the curlpp.pc file in do_install_append to avoid the following QA error. ERROR: QA Issue: curlpp.pc failed sanity test (tmpdir) The problem occurs only for tunes which set baselib to 'lib32', and in OE, we only have two tunes which set such value. BASE_LIB_tune-octeon2 = "lib32" BASE_LIB_tune-octeon3 = "lib32" Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/curlpp')
-rw-r--r--meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb b/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb
index 78b943247d..bbba576caa 100644
--- a/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb
+++ b/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb
@@ -20,6 +20,10 @@ inherit autotools-brokensep pkgconfig binconfig
# deprecated auto_ptr. For now, ignore the issue.
CXXFLAGS += "-Wno-error=deprecated-declarations"
+do_install_append () {
+ sed -i 's,${STAGING_DIR_TARGET},,g' ${D}${libdir}/pkgconfig/curlpp.pc
+}
+
PACKAGES =+ "libcurlpp libcurlpp-dev libcurlpp-staticdev"
FILES_lib${BPN} = "${libdir}/lib*.so.* \