aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/dnsmasq/dnsmasq
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2014-08-11 09:12:25 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-08-13 23:28:04 +0200
commitf1e112fa688aa0900ebdbcc31d88c6ce91251495 (patch)
tree126e6ab82a079527e6992fb60d777ab758cbf7bb /meta-networking/recipes-support/dnsmasq/dnsmasq
parenta46abacebdf83cd20f421828435e0403f5f3eb8d (diff)
downloadmeta-openembedded-contrib-f1e112fa688aa0900ebdbcc31d88c6ce91251495.tar.gz
dnsmasq: look for lua.pc, not lua5.1.pc
Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/dnsmasq/dnsmasq')
-rw-r--r--meta-networking/recipes-support/dnsmasq/dnsmasq/lua.patch16
-rw-r--r--meta-networking/recipes-support/dnsmasq/dnsmasq/parallel-make.patch19
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/dnsmasq/dnsmasq/lua.patch b/meta-networking/recipes-support/dnsmasq/dnsmasq/lua.patch
new file mode 100644
index 0000000000..aac7b97a16
--- /dev/null
+++ b/meta-networking/recipes-support/dnsmasq/dnsmasq/lua.patch
@@ -0,0 +1,16 @@
+Upstream-status: Inappropriate [OE specific]
+Signed-off-by: Christopher Larson <chris_larson@mentor.com>
+
+--- dnsmasq-2.68.orig/Makefile 2014-08-11 09:05:17.000000000 -0700
++++ dnsmasq-2.68/Makefile 2014-08-11 09:05:51.930648617 -0700
+@@ -57,8 +57,8 @@
+ idn_libs = `echo $(COPTS) | $(top)/bld/pkg-wrapper HAVE_IDN $(PKG_CONFIG) --libs libidn`
+ ct_cflags = `echo $(COPTS) | $(top)/bld/pkg-wrapper HAVE_CONNTRACK $(PKG_CONFIG) --cflags libnetfilter_conntrack`
+ ct_libs = `echo $(COPTS) | $(top)/bld/pkg-wrapper HAVE_CONNTRACK $(PKG_CONFIG) --libs libnetfilter_conntrack`
+-lua_cflags = `echo $(COPTS) | $(top)/bld/pkg-wrapper HAVE_LUASCRIPT $(PKG_CONFIG) --cflags lua5.1`
+-lua_libs = `echo $(COPTS) | $(top)/bld/pkg-wrapper HAVE_LUASCRIPT $(PKG_CONFIG) --libs lua5.1`
++lua_cflags = `echo $(COPTS) | $(top)/bld/pkg-wrapper HAVE_LUASCRIPT $(PKG_CONFIG) --cflags lua`
++lua_libs = `echo $(COPTS) | $(top)/bld/pkg-wrapper HAVE_LUASCRIPT $(PKG_CONFIG) --libs lua`
+ sunos_libs = `if uname | grep SunOS >/dev/null 2>&1; then echo -lsocket -lnsl -lposix4; fi`
+ version = -DVERSION='\"`$(top)/bld/get-version $(top)`\"'
+
diff --git a/meta-networking/recipes-support/dnsmasq/dnsmasq/parallel-make.patch b/meta-networking/recipes-support/dnsmasq/dnsmasq/parallel-make.patch
new file mode 100644
index 0000000000..6d5b722eab
--- /dev/null
+++ b/meta-networking/recipes-support/dnsmasq/dnsmasq/parallel-make.patch
@@ -0,0 +1,19 @@
+The dnsmasq target depends on .configured and $(objs). .configured does an rm
+-f *.o. Yet the only thing telling make to build the .configured target before
+the $(objs) target was the order of the dependencies of the dnsmasq target. We
+can't rely on that order when doing a paralllel make build, so add an explicit
+rule to enforce that order.
+
+Signed-off-by: Christopher Larson <chris_larson@mentor.com>
+Upstream-status: Pending
+
+--- dnsmasq-2.68.orig/Makefile
++++ dnsmasq-2.68/Makefile
+@@ -139,6 +139,8 @@ bloatcheck : $(BUILDDIR)/dnsmasq_baselin
+ @rm -f *.o
+ @touch $@
+
++$(objs): .configured
++
+ $(objs:.o=.c) $(hdrs):
+ ln -s $(top)/$(SRC)/$@ .